Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have checked the mouse settings to make sure that the mouse does not activate a window merely by hovering (that box is unchecked) and I have installed a new mouse and a new keyboard and made sure that my USB drivers and mouse-drivers are up-to-date. I have also disabled anti-virus. I have also made sure that devices do not participate in any power-management scheme (that option is grayed out in any event). But nothing seems to fix this problem.

This problem occurs in both regular mode and Safe Mode.

And here's the problem described in greater detail:

Sometimes when I click on a partially obscured window, it does not become the active window. The partially obscured window could be running almost anything -- Notepad, Microsoft Money, a browser, there's no pattern there. And yet sometimes when I allow the mouse merely to hover over a partially obscured window, it comes forward, just like the task bar/auto-hide toolbar will pop out from "behind" the monitor when the mouse moves over its region on the edge of the screen. When the partially obscured window doesn't come forward when clicked, it's just like the topmost window has been opened like a "modal dialog".

Here's how I temporarily fix this problem: Ctrl-Alt-DEL and then click the CANCEL button to return to the desktop. NOTE, the CANCEL button always takes two clicks. On the first click it does not respond. When I return to the desktop, things function as they should, for a few minutes.

A gazillion people have reported this problem -- there's a thread on Microsoft Technet about it-- but the MSFT techies there are blaming it on defective hardware --a malfunctioning mouse/keyboard or bad motherboard. I've changed out the mouse and keyboard, but I cannot swap out the motherboard. However, I have run the M/B manufacturer's diagnostics which report that the USB ports are working correctly, FWIW.

The properties tabs in Device Manager also all say that the devices are functioning properly.

This has been going on for over a week and is driving me up the wall, since it happens every few minutes. I hope someone here has a bright idea about how to fix it.

share|improve this question
    
This sounds like a situation where a restore point might come in handy. Do you have any? You can check in system restore. It will roll back system/driver changes to a period where it worked without affecting data. At the very least, restoring to a point prior to the issue and still having it occur will narrow down causes. –  EntropyWins Sep 14 '12 at 13:03
    
Thanks, I may have to start rolling back. Just bought a new Microsoft keyboard thinking possible conflict with third-party wireless kb dongle. Same problem. :-( –  MrBlint Sep 15 '12 at 14:46
    
"System Restore did not complete successfully. Your computer's system files and settings were not changed. An unspecified error occurred during SYstem Restore (0x80071a90)". Arrrgh. P.O.S.O.S. –  MrBlint Sep 15 '12 at 14:52
add comment

2 Answers 2

I stumbled upon this page because I also was experiencing the issue.. click on any open application in the task bar and it would not pop up.. eg, google chrome, lotus notes, lotus sametime, etc, etc.. after reading this, I was able to resolve it with the following steps:

  • Don't ask me why, but I right clicked on the desktop, clicked personalize.. at the bottom of the window that comes up, there is a link to "troubleshoot problems with transparency and other Aero effects" ...

  • I ran that which comes up and asks if you would like it to automatically fix found errors.. I just clicked next there.. it looks for troubles and comes up and displays a message about the fact it cannot run while there are mirrored drivers such as microsoft remote assistance or live mesh...

  • I clicked next, it tries to run again and fails saying again in plain english, it cannot run with mirror drivers.. I had the pivotal.. hmmm moment and so killed the processes for Teamviewer, Logmein Hamachi and just for kicks an Asus utility for my TF101...

I did nothing else but the issue stopped occurring..

Now.. I havent had the time to try delaying start up of these apps or any other permutations but I have ran hamachi/logmein for more than 7 years with no issues or conflicts.. teamviewer is a relatively new add but still I run it on multiple machines with no previous issues.. the asus utility has been on here for at least a year, since that's about how long I've had the tablet..

(let me make an aside comment here.. some are probably saying, why the #$@#$^ would you run two remote apps at once.. the answer is because when I am remote and I need to remote, I need it to work.. it's critical.. there are RARE occasions where one or the other app may hose up with a direct connection but the other one can be accessed still from another box I have locally..)

so back to this issue.. why now?? Can't say.. if I had to speculate.. I would probably go towards the recent MS patches not necessarily as the "cause" but I suspect it may have changed some of the dynamics on the system. I have yet to reboot so we'll see..

There are so many dynamics from machine to machine so I make no claim that this is "it" for the fix.. some times these things work for others which is the sole reason I am sharing.. This is a Thinkpad T400, Win 7 64bit, MS Office 2010, Lotus Notes, Sametime other products for video editing, etc.. and the build is several years old...

share|improve this answer
add comment

Right click desktop then change the theme you are using

This fixed this problem for me

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.