Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Id like to disable the low disk space warning, ideally for a single drive in Windows 8.

My gut feeling is that is it will be an all or nothing change.

Any ideas?

share|improve this question
5  
It is indeed all or nothing. The method I'm aware of is a Windows Explorer Policy setting, or a registry change (HKCU\Software\Microsoft\ Windows\CurrentVersion\Policies\Explorer) for NoLowDiscSpaceChecks. That seems pretty convincing to me that it's all or nothing. –  user3463 Sep 14 '12 at 17:25
    
yeah, Ive seen that too, but I was hoping someone might know of a localized change. –  Keltari Sep 14 '12 at 17:28
    
What is the low space threshold? 10%? I can lower the pagefile size as not to trigger the warning. –  Keltari Sep 14 '12 at 17:49
    
2  
The key name is NoLowDiskSpaceChecks not NoLowDiscSpaceChecks. –  gdoten Apr 26 '13 at 18:02

5 Answers 5

The documented method of disabling the log disk-space warning is described in this KB article

To remove this irritating pop up do the following

  1. Start > Run > Regedit > OK
  2. Now navigate to the following location HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
  3. Right Click on the blank area of the right pane of the registry editor and create a new DWORD Value by selecting New > DWORD Value.
  4. Name this newly created DWORD Value -"NoLowDiskSpaceChecks"
  5. Now double-click on the new DWORD and assign it the value 1.
  6. Close the registry editor and restart the system.

This is a per-user setting and cannot be set on disk-by-disk basis.

The way that Windows 7 and earlier chose whether or not to display this warning for a drive is described by Raymond Chen here, however it might be different for Windows 8.

share|improve this answer

Can some people please read before they re-post?

Theory: Microsoft says: DisableLowDiskSpaceBroadcast is for disabling the warning when copying files to a disk ONLY. So this is not the warning that appears in the tray, but the window that recommends cleaning the disk as soon as copying is about to fail. This key can be set for individual disks. Microsoft describes it for Windows 7 only. Practical: With Windows 8, I found this key will not disable the tray warning for my backup medium. So the posting of Darth Android is proven to be wrong, while Microsoft might be right.

NoLowDiscSpaceChecks disables the warning in the tray. This can be set for a user, not for a single disk. This key is said to work with Windows 7+8.

share|improve this answer

I ran into the problem on a drive I set up for Window's page file (so it would not be included in a system backup). I tried to use the as much of the drive as I could; but I started getting the errors. My solution was simply to reduce the size of the allocated page file by 200MB. Not that big a deal relative to the full 6GB of the drive.

share|improve this answer

I tried all the above suggestions and only one worked. The drive that is always popping up the low disk space message is the same drive I have my swap file on.

What Finally worked for my windows 7 enterprise it to set the swap file to a fixed length at about 300 MB less than the total space of the drive. Windows starts complaining about low disk space when 200 MB or less remain.

I hope this helps some one.

One thing to note is low disk space can suspend System Restore on that disk. If any disk is suspended, System Restore is suspended on all disks. So no System Restore points will be created. see http://support.microsoft.com/kb/300044 for more information

share|improve this answer

Try the following:

  1. Open Regedit
  2. Navigate to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem
  3. Create a new DWORD called DisableLowDiskSpaceBroadcast and set its value to a number based on the drive you want to disable notifications for:


Drive Letter   Data Value  

A                      1  
B                      2  
C                      4  
D                      8  
E                     16  
F                     32
G                     64
H                    128
I                    256
J                    512
K                   1024
L                   2048
M                   4096
N                   8192
O                  16384
P                  32768
Q                  65536
R                 131072
S                 262144
T                 524288
U                1048576
V                2097152
W                4194304
X                8388608
Y               16777216
Z               33554432

NOTE: If you want to disable the error message for more than one drive, you can add the data values of the drives located in the table, and then set the data value of the DisableLowDiskSpaceBroadcast value using the sum of the data values that you added. For example, drive E has a value of 16 and drive G has a value of 64. These two data values added together equal 80. To disable the low disk space notification for drive E and drive G, set the data value of the DisableLowDiskSpaceBroadcast value to 80.

Soruce: http://support.microsoft.com/kb/188074

share|improve this answer
2  
Downvoted. I cannot get this method to work under Windows 7, and I'm pretty sure this would be the case under Windows 8 as well. The cited source only mentions Windows 98, and even gives a warning that it doesn't work with my operating system (as detected by the page.) –  nitro2k01 Oct 27 '13 at 12:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.