Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was having trouble installing irssi (brew install irssi), so I ran brew doctor, which returned a warning mentioning an outdated copy of Xcode and saying I should run /Developer/Library/uninstall-developer-folder. Then I ran brew doctor again and got:

Error: No such file or directory - /Developer/SDKs/MacOSX10.6.sdk

How do I reinstall the SDK, or is there another way to get Homebrew working again?

(I have the latest version of Homebrew (0.9.3), the latest version of Xcode (4.4.1), and the latest version of the Xcode CLT (though I'm not sure how to find this version number).)

UPDATE: /Developer actually still exists (despite the obvious implication of uninstall-developer-folder), as does /Developer/SDKs/MacOSX10.7.sdk. Why does Homebrew specifically need Snow Leopard's SDK?

share|improve this question
    
Do you have a current brew, a current Xcode, and current Xcode command-line tools? –  Daniel Beck Sep 15 '12 at 9:14
    
Yes, yes, and yes. Updated the question to reflect this. –  Blacklight Shining Sep 15 '12 at 10:42

1 Answer 1

up vote 0 down vote accepted

The installer for Xcode 4.3 should have removed /Developer/. I guess brew doctor just checks if it exists. I was able to install irssi without it.

Newer versions of the SDKs should be in /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/.

You could probably just delete /Developer/ completely. See Uninstall Xcode 4 when it was installed via the App Store and How to remove previous versions of Xcode.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.