Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have the following problem. First I had images and other elements labeled just by number, so from 1 to ∞. When I cross referenced I changed to number only using the following:

{ REF _Ref334952863 \# 0 \h }

And it worked fine, I got only the image number. Then I found new instructions, saying I have to change captions to paragraph.number, like so:

enter image description here

But my referencing now is completely broken, all I get is number 4. What I need is 2.2, so number without the label. If I leave label it works, I can get Slika 2.2, but I can't use the label.

The reason is, unlike English, my language uses declination, and I cannot use "slika" everywhere, sometimes it's "slike" or "sliki" and sometimes I just want to use number in brackets only [2.2].

share|improve this question

3 Answers 3

The workaround with # 0.0 or # 0 in the answer above work only for one-digit numberings. (according to http://answers.microsoft.com/en-us/office/forum/office_2007-word/how-to-disply-figure-number-only-in-cross/02ae3cd0-6c3c-401d-990c-5220d7f0be1e).

But you can use the "kludgy workaround": http://wordfaqs.mvps.org/CombineXrefs.htm

In short, 10 simple steps:

  1. Use classic "Add cross reference" to Slika 2.2
  2. Press Shift+F9 to show field code. You shoud see something like { REF _Ref107244825 } instead of Slika 2.2.
  3. Select and copy the _Ref107244825 part.
  4. Press Shift+F9 again.
  5. Go to the caption of Slika 2.2 (e.g. by Ctrl+click on the inserted reference)
  6. Select the 2.2 part of the caption
  7. Open the "Insert bookmark" dialog
  8. In the dialog, check the "Show hidden bookmarks" checkbox
  9. Find the _Ref107244825 (you can e.g. paste the copied text from step 3)
  10. Click "Add" and then close the dialog

Now, when you actualize the fields (e.g. press F9), the reference becomes 2.2 and you can add declined "Na slike".

share|improve this answer

Instead of \# 0, try adding \# 0.0. That way, you would only get the paragraph.number format (so, the actuall hyperlink would only include the "2.2" part, and you would add the "slika" part as plain text in front).

If you would like to add some text inside the hyperlink (so a wider area than 3-4 characters is clickable), I suggest adding it as custom text, enclosed in single-quotes:

{ REF _Ref334952863 \# "'na slici' 0.0" \h }

So, the example you mentioned would look like this:

{ REF _Ref334952863 \# "'['0.0']'" \h }

P.S. Don't forget that if you want to add multiple things to the \# declaration, you have to enclose them in double-quotes.


Sources:

share|improve this answer
2  
I only get 01, 02, the first number is always 0 –  Bojan Kogoj Feb 28 '13 at 19:55
    
Well, are you sure you "told" word that you've started a new chapter by using the apropriate style? By default, this is "Heading 1". All figures inserted before the begining of the first chapter would be labeled with a leading zero. –  Mandark Mar 1 '13 at 18:54
1  
It just doesn't work. All i get is [01],[02]. I can get the dot by putting it into single quote. I used heading 1 and there was no effect –  Bojan Kogoj Mar 2 '13 at 0:52
    
Have you found the solution yet? –  Michal Kováč Oct 14 '13 at 9:14
    
I’ve seen this solution in several places on the web. Either it does not work at all and everybody copies it without checking, or it only works in English. (There’s a decimal point involved, so I wouldn’t put it past Microsoft to mess this up.) –  Florian Jenn Oct 14 at 16:48

I came up with a little workaround for this problem. It's not the neatest solution but it works if you need this feature desperately. It works with figures, tables, whatever. What i do is:

Suppose i have a figure followed by the figure title which is something like: Figure 5.23 Effect of temperature on parameter Z

I create a 2-columned, single row table where i - type "Figure" on the leftmost cell - insert the caption (in this case 5.23) followed by the title text in the right cell

Then i just put the table really close to my figure so that i don't end up with an ugly gap between the figure and the figure title.

Essentially, this separates the word "Figure" from the caption so you can type whatever you want before your cross-references. The only downside is that if you create a Table of Figures, you will have to type the word "Figure" to the left of the figure reference number by hand for every single figure but that's not a deal breaker in my opinion. Cheers.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.