Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've set up a scheduled task in Windows 7 Pro to open up Internet Explorer 9 (x86 version) in kiosk mode. The scheduled task executes when a certain user logs in, and this user is logged in automatically when Windows starts.

This is the command I'm using to start IE:

"C:\Program Files (x86)\Internet Explorer\iexplore.exe" -k http://example.com

So far so good - the computer boots up, the user gets logged in, and IE opens up in kiosk mode. The problem is that IE seems to open behind the taskbar - so the taskbar (start menu, pinned programs, etc.) appears at the bottom of the window, and the bottom of the IE window is visible through the taskbar (since the taskbar is translucent).

Is there anything I can do, preferably without installing any third party programs (although I will go for that option if none other is available), to ensure that the IE9 kiosk window always opens in front of the taskbar?

share|improve this question
    
Have you tried turning auto-hide on for the taskbar? Have you tried a Startup script GPO instead? –  imtheman Sep 16 '12 at 5:21
    
Setting the taskbar to auto-hide will do nicely - I didn't even think of that! –  greg27 Sep 17 '12 at 5:21
    
Ok great, I'll post it as an answer. –  imtheman Sep 17 '12 at 16:05
add comment

1 Answer

up vote 1 down vote accepted

Set the taskbar to Auto-hide and that will prevent it from showing above your full screen application.

share|improve this answer
    
Perfect workaround, thanks. –  greg27 Sep 17 '12 at 23:36
    
You're very welcome. –  imtheman Sep 18 '12 at 0:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.