Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Having trouble with Postgres since I upgraded to Mountain Lion (and now regretting it). Lost hours trying to fix it to no avail.

When running rails server then visiting my app at 0.0.0.0:3000 I get this error.

psql: could not connect to server: No such file or directory. Is the server running locally and accepting connections on Unix domain socket "/var/pgsql_socket/.s.PGSQL.5432"?

tried updating xcode.

share|improve this question

migrated from stackoverflow.com Sep 16 '12 at 8:54

This question came from our site for professional and enthusiast programmers.

    
Can you verify that postgres is in fact running? –  nneonneo Sep 15 '12 at 8:36
    
'ps aux | grep postgres' yields '1870 0.0 0.0 2432768 596 s002 S+ 1:38AM 0:00.01 grep postgres' –  kurtybot Sep 15 '12 at 8:40
1  
That would suggest that postgres is not running (the only output is the grep command itself). So maybe you need to reinstall PostgreSQL? –  nneonneo Sep 15 '12 at 8:41
    
maybe. i know that mac osx mountain lion has it by default, but how to set that up with rails isn't clear to me. gonna try brew install postgresql and see what happens. –  kurtybot Sep 15 '12 at 8:54
    
did brew install postgresql and still have the same error –  kurtybot Sep 16 '12 at 20:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.