Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've updated the kernel on my Linux Mint following this tutorial. But now, when I try to install the latest fglrx, I'm getting this error:

Check if system has the tools required for installation. fglrx installation requires that the system have kernel headers. /lib/modules/3.5.0-030500-generic/build/include/linux/version.h cannot be found on this system. One or more tools required for installation cannot be found on the system. Install the required tools before installing the fglrx driver. Optionally, run the installer with --force option to install without the tools. Forcing install will disable AMD hardware acceleration and may make your system unstable. Not recommended.

I tried to run sudo apt-get install linux-headers-$(uname -r), but it says it's already the latest version. Any help?

share|improve this question
    
The package manager seems to be saying that the headers should be there. Is it possible that something has trashed the headers directory? Maybe try forcing a reinstall of the headers to make sure they're present. –  killermist Oct 3 '12 at 15:22

2 Answers 2

up vote 0 down vote accepted

Rather than an answer, I will give you some questions :). Are you sure that you have booted into your new kernel? What is the output of uname -a? What are the contents of /lib/modules/ ?

My guess is that you have simply not loaded your new kernel.

share|improve this answer
1  
Thanks a lot! Your answer helped me to figure it out by myself, I was missing symbolic link /lib/modules/3.5.0-030500-generic/build linking to /usr/src/linux-headers-3.5.0-030500-generic –  Pavel Plzák Sep 16 '12 at 13:21
    
I have the same issue. This is the list of all version.h files that I have in my Fedora 20 desktop. /usr/src/kernels/3.12.9-301.fc20.x86_64/include/generated/uapi/linux/version.h /usr/src/kernels/3.12.9-301.fc20.x86_64/include/xen/interface/version.h /usr/src/kernels/3.12.9-301.fc20.x86_64/include/config/arch/want/compat/ipc/par‌​se/version.h /usr/src/kernels/3.12.9-301.fc20.x86_64/include/uapi/linux/dvb/version.h /usr/include/alsa/version.h /usr/include/linux/dvb/version.h /usr/include/linux/version.h What shall I do? –  noufal Feb 8 at 2:09
    
@noufal please post a new question explaining your issue. The issue here was that the OP had not booted into their new kernel. –  terdon Feb 8 at 14:40

It may be that the installer/driver only works with kernels up to 3.4 - "Automated installer and Display Drivers for Xorg 6.9 to Xserver 1.12 and Kernel version up to 3.4" from amd website. For me with a later kernel (3.8.0-33) it didn't reject the kernel version but fails and can't find /lib/modules/3.8.0-33-generic/build/include/linux/version.h - apt-file tells me no such file exists.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.