Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to set-up an access point (ad-hoc) for my Raspberry Pi. That means I'm trying to "share" the ethernet connection over Wi-Fi. I am doing this using my Ralink Technology, Corp. RT2501/RT2573 Wireless Adapter. When following a tutorial (or actually every tutorial), it immediately goes wrong.

root@pinkypi:/home/pi# iwconfig wlan0 mode ad-hoc
Error for wireless request "Set Mode" (8B06) :
 SET failed on device wlan0 ; Device or resource busy.

I already tried ifdown and not having it in the USB port at the startup.

If it helps, every action with the thing fail (or at least setting the mode). I am using Debian.

I'm sure I'm overseeing something, but I can't find out what. What is wrong?

share|improve this question

Have you tried running the command with admin privileges, ie prefix the command with sudo:

sudo iwconfig wlan0 mode ad-hoc

share|improve this answer
As you can see in the codeblock, I am doing this all with the "root" user. So, yes. – Wouter Sep 17 '12 at 20:26

What does the kernel say? (If anything)

Have you tried to bring the interface up with 'ifconfig wlan0 up' before setting the mode?

It might also be worth checking if the device can be used in ad-hoc mode on another box, possibly with a recent distro.

share|improve this answer

I am having the same issue. I was able to successfully start an ad hoc network on on my raspi by first creating one in wicd and then from the command line. I get the error if I try to start ad hoc on boot. Wicd must be changing modes for me before I try to bring up ad hoc, but I need to find out what it is doing to replicate it on boot. Does anyone know how to find out what wicd is doing or any way to fix this issue. I have already tried using ifconfig wlan0 up/down and there is no difference.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .