Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My girlfriend's work computer now has Linux on one of the partitions, and for the most part it's running fine--except that I can't seem to get the network printers configured right. There are two of them: a Lanier MP 7500/LD275 and a Lanier MP C3000/LD430c, and Linux seems to have found them both automatically. I'll go through the steps of what I did, and what exactly went wrong.

I went to Administration > Printing, and clicked the new printer button. It searched for printers and found them both, listed under "Network Printers." I added them as new printers in succession. However, when I clicked "Print a Test Page," it failed saying there was a broken pipe. The device URIs were saved as socket://[ip address]:9100. I changed these to lpd://[ip address] per some online tutorial, which at first looked like it might have worked (but didn't). Then when I tried to print a test page, it first said Processing (and sometimes even Processing - printing test page, 4%, but always subsequently displays Idle - /usr/lib/cups/backend/lpd failed.

Help! What do I do? It seems like Linux can find these printers just fine, and the drivers seem to be in place, so what's going wrong?

share|improve this question

migrated from stackoverflow.com Sep 27 '09 at 19:31

This question came from our site for professional and enthusiast programmers.

2 Answers 2

up vote 2 down vote accepted

The Windows side of this computer does print to both printers, right? If not, this machine may not be allowed to print to them.

Assuming the Windows side prints OK, your next step is to check the CUPS error log at /var/log/cups/error_log. Anything interesting there?

According to this post on the Ubuntu forums, one Jaunty user had a problem with automatic PPD download. Check that the directory /usr/share/cups/model exists, and manually create it if it doesn't (like so):

sudo mkdir /usr/share/cups/model
sudo chmod 755 /usr/share/cups/model

If you needed to create that directory, try deleting and re-adding the printers from the Administration > Printing tool. I expect you'll need to use the original "socket://" URI and not the "lpd://".

If that doesn't work, you'll need to do some more digging. Here's some pages at the OpenPrinting database that will help. First, both printers seem to be well supported:

Ubuntu uses CUPS, and both printer pages above link to this CUPS documentation. You've gone through the first step, which is to try the distribution's own tool, but that's not quite working. You may need to download PPD files manually from the printer pages above. This FAQ talks about how to install PPD files:

How do I install a PPD file?

Use command line or CUPS web interface.

* Command line installation.   (updated for Ubuntu)
  $ sudo /usr/sbin/lpadmin -p replace_with_printer_name -E -v socket://replace_with_printer_ipaddress:9100 -P replace_with_ppd_name 

* CUPS web interface.
  Open http://127.0.0.1:631/printers from your browser, click "Add Printer" and follow the steps.

Check the rest of the FAQ for other interesting possible solutions. (Like UserCodes your driver may need to send to the printer to authorize a print job. Wheee!)

share|improve this answer
    
Thanks for your response. I just saw this now (I'm still getting used to this stackoverflow.com not actually at stackoverflow.com business), so I'll try this and let you know what I find. –  SoaperGEM Oct 1 '09 at 14:45

I had similar problems and simply solved them selecting "Other" in Add Printer options from System tab.

Then I typed socket://My-Printer_Server-IP:9100, then selected the driver for installation.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.