Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to grant permission to a file from the command line for the user IIS6.0.

So far I've tried icacls /grant ISS_WPG:(RX,W) 'namefile', but with no result.

share|improve this question
    
What you mean W here (RX, W)? –  Siva Charan Sep 17 '12 at 12:42
    
W = Write permission. RX= Read & Execute –  Raffaello Oct 4 '12 at 16:49
add comment

1 Answer

up vote 0 down vote accepted

The correct syntax is:

icacls FILE /grant USER:(RX,W)

The filename goes first.

share|improve this answer
    
thanks for the anwser, More specific, i have error on 'USER:' list: -If I want to grant access to a directory for 'Everyone', I have to use this syntax? 'icacls DIR_NAME /grant Everyone:(RX,W)' –  Raffaello Sep 17 '12 at 11:54
    
Yes, although you may want to add (CI)(OI) to enable inheritance: icacls DIR_NAME /grant Everyone:(CI)(OI)(RX,W) –  Ansgar Wiechers Sep 17 '12 at 13:15
    
thanks very much. you're answer is usefull!!! –  Raffaello Sep 17 '12 at 14:15
    
Well, if it is, consider accepting it. ;) –  Ansgar Wiechers Sep 17 '12 at 16:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.