Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying install Linux on my computer (tried Ubuntu 10.4 and Linux Mint 9).

I started the installation wizard and on the hard disk selection page the hard disk is not displayed. I have a 500GB disk with 5 partitions and windows 7 ultimate in one partition. If I click the forward button, it shows an error- "No root file system defined".

I have tried to install by booting from CD and pendrive but both shows the same error.

When I load Linux as live CD it doesn't show the hard disk.

My hard disk works fine in windows 7.

System config:
intel i3 2100,
500GB hdd,
2GB ram

share|improve this question

migrated from Sep 17 '12 at 12:47

This question came from our site for professional and enthusiast programmers.

This hard drive, is it an IDE (OLD) hard drive? If not, you might be running it in IDE (compatible) mode.


  1. Upgrade your harddrive to a ATA one.
  2. Disable compatibility-mode in BIOS.
  3. Find a linux distribution with a kernel that supports IDE drives.
share|improve this answer
it is a SATA drive and it is not in compatibility-mode – Syam Kumar S Sep 18 '12 at 6:15

Check from LiveCD with:

#fdisk -l

or start GParted.

P.S.:You should remember, that you cannot have more than 4 primary partitions with MBR.

see this link for details: here

share|improve this answer
Actually you can, with the GUID (GPT) partitioning scheme. The limit of 4 partitions is specific to MBR. – MSalters Sep 17 '12 at 14:19
i opened GParted from live cd ,but my hdd is not shown there. I have 2 primary partition and 3 extended parttions – Syam Kumar S Sep 18 '12 at 6:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .