Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Windows 8 Enterprise x64. It's installed a virtual machine. After trying to update VMWare's guest extension it black screened. After resetting it, now the virtual machine won't boot. It just says "automatic repair couldn't repair your PC"

Everything I do ends with an error or it coming back to this screen. If I go to Troubleshoot > Advanced Options > Start up settings and then go to Safe Mode, all it will do is say "preparing automatic repair" and then "diagnosing your PC" and then will come straight back to the "automatic repair couldn't repair your PC" screen. It's as if it doesn't even attempt to go into safe made.

Is there anything else I can do before I reformat?

share|improve this question
    
It sounds like you have tried all the normal supported methods. If Windows Repair Console is unable to repair the problem you are literaly out of options. –  Ramhound Sep 17 '12 at 14:51
    
Yea, even doing a "reset PC" which sounds like a reformat won't work, nor will attempting an upgrade using the Windows 8 disk. Time to reformat I suppose –  Earlz Sep 17 '12 at 14:55
    
Add Safe Mode to the initial Boot menu, it shortens the process a bit, this link is for W7 but I just tried it on W8 and works...sevenforums.com/tutorials/… –  Moab Sep 17 '12 at 20:04

5 Answers 5

up vote 16 down vote accepted

Things are a little bit different in Windows 8. Have a look at the HowToGeek guide for this which explains in detail what you may be trying to achieve.

In summary:

  1. Mash Shift+F8 like you would with F8
  2. Click See advanced repair options
  3. Choose Troubleshoot
  4. Choose Advanced options
  5. Choose Windows Startup Settings
  6. Click Restart

Windows 8 Safe Mode

share|improve this answer
1  
When I go to safe mode it just reboots and says "preparing automatic repair" –  Earlz Sep 17 '12 at 14:55
    
Then select disable automatic restart from this menu –  Canadian Luke Sep 17 '12 at 14:57
    
@Luke I should've, but I didn't have too much stuff on it, so I figure faster to just reinstall than try to repair it now. –  Earlz Sep 17 '12 at 15:00
    
@Earlz then try to repair it through the installation disk. –  avirk Sep 17 '12 at 15:08
2  
@Ramhound what are you smoking, it is not the same thing, try it on your Windows 8 PC its a 7 step process including and extra restart of the PC, Absolutely nothing like W7 –  Moab Sep 17 '12 at 20:03

Shift + F8 does not work....never !!!

I recently figured out a way to restart the computer in safe mode without using msconfig and charms bar. Here is how to do it.

  1. When you are at login screen hold the shift key
  2. Click on shutdown option available at right bottom corner and click on restart
  3. Now windows 8 should start to its usual advanced menu, where you can chose startup options to go to safe mode and other diagnostic modes or troubleshoot to go to Recovery Environment.

Try this it works !

share|improve this answer
    
This worked for me. I've tried SHIFT+F8 dozens of times and it wasn't working at all! Thank you!!! –  Mark J Miller Feb 13 at 12:42
    
I'm surprised other people aren't seeing this issue too. Shift + F8 never, ever works for me either. I can't help but wonder why - it could be a lot of things but off the top of my head...maybe our keyboards are unresponsive during this part of boot time or Windows is corrupted... –  Alexandru Apr 15 at 12:53
    
Probably the retarded FN (Function) key where some manufacturers make ALT+F4 do nothing so you have to press ALT+FN+F4 to make it close a program...you can usually fix it back to the normal function keys in the bios. –  John Aug 8 at 5:35

Run Command prompt as Admin and type (copy/paste the following line):

bcdedit /set {default} bootmenupolicy legacy

Press Enter.

Now you have safe mode as usual from the boot screen.

To revert:

bcdedit /set {default} bootmenupolicy standard
share|improve this answer
    
Since I had never heard of bcdedit before, I'm going to include the reference to it: technet.microsoft.com/en-us/library/cc709667(v=ws.10).aspx –  Ehtesh Choudhury May 13 '13 at 20:26
    
I tried this in Windows 8.1 but it does not work. I need to change the safe-mode booting in command line... Is there any other option? –  jaeyong Sep 25 at 12:17

Microsoft actually has changed the F8 hotkey to Shift + F8 but didn't mention it.

Source:

The trick is to hold the Shift button and mash the F8 key, this will sometimes boot you into the new advanced "recovery mode", where you can choose to see advanced repair options.

share|improve this answer

Well, since no one else has a suggestion that works, I'd say (depending on how you obtained this ISO...) to check the SHA 1 hash of the ISO to see if it is corrupted in some way - if it doesn't match up, redownload. I am sure you will be able to find the hash somewhere online.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.