Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm a newbie to Linux (that mainly uses Windows and Mac OS X) needing some advice. I was trying to install git on a Linux machine today, and encountered some problems:

  1. Not knowing the version of the installed OS, I've opened the /proc/version file which said:

    Linux version 2.6.9-42.0.2.ELsmp (bhcompile@ls20-bc1-13.build.redhat.com) 
    (gcc version 3.4.6 20060404 (Red Hat 3.4.6-3)) #1 SMP Thu Aug 17 17:57:31 
    EDT 2006
    
  2. Then, as written in the git documents (http://git-scm.com/download/linux), I assumed I could use the yum install git command for Fedora, but got the following result.

    [root@myserver ~]# yum install git
    -bash: yum: command not found
    
  3. So I tried installing yum using wget, but wasn't so lucky.

    [root@myserver ~]# wget http://linux.duke.edu/projects/yum/download/2.0/yum-2.0.7.tar.gz
    -bash: wget: command not found
    
  4. I googled and found this page and this page, so tried installing yum with rpm, but only got a result full of question marks. (Possibly an encoding problem, hmm...)

    [root@myserver ~]# rpm -Uvh http://www.eomy.net/linux/install-yum-x86_64/wget-1.10.2-0.40E.x86_64.rpm
    http://www.eomy.net/linux/install-yum-x86_64/wget-1.10.2-0.40E.x86_64.rpm(??)?? ?????ϴ
                                                                                  ?: /var/tmp/rpm-xfer.TbuAOu: V3 DSA signature: NOKEY, key ID 443e1821
    ?غ?..                  ########################################### [100%]
    wget-1.10.2-0.40E Ű????̹??ġ?Ǿ?ֽ??ϴ
                                            wget-1.10.2-0.40E???? ??ġ?Ǵ/usr/bin/wget ?? wget-1.10.2-0.40E Ű????ϰ? ???ϴ
                                                                                                                            wget-1.10.2-0.40E???? ??ġ?Ǵ/usr/share/man/man1/wget.1.gz ?? wget-1.10.2-0.40E Ű????ϰ? ???ϴ
                                             [root@myserver ~]# 
    
  5. Finally, when I typed rpm --version in the terminal, I got the below results.

    [root@myserver ~]# rpm --version
    RPM ???? - 4.3.3
    

I would like to know what I can do or possibly try now. Is it not possible to wget or yum anything in my situation? Or is there any magical tool like homebrew (http://mxcl.github.com/homebrew/) that I can use?

As jhcaiced has mentioned in his comments, I've added the output of some more files:

  • vi /etc/issue

    Red Hat Enterprise Linux AS release 4 (Nahant Update 4)
    Kernel \r on an \m
    
  • vi /etc/redhat-release (no file named /etc/release)

    Red Hat Enterprise Linux AS release 4 (Nahant Update 4)
    
  • /etc/version and /etc/release-version do not exist.

Plus, no apt-get and no yast in the system. The 32 bit packages didn't work either.

share|improve this question

migrated from stackoverflow.com Sep 17 '12 at 15:00

This question came from our site for professional and enthusiast programmers.

2  
You don't have apt-get either, I take it? – Alex D Sep 17 '12 at 12:07
    
Have a look at linuxers.org/howto/… – Jacob Tomlinson Sep 17 '12 at 12:09
    
How did you decide on downloading the x86_64 version of the packages? Might it not be the case that you're running a 32 bit system and that you should use those packages instead? – HonkyTonk Sep 17 '12 at 12:11
    
Also, you have to remember that Linux has many different package managers. Fedora and RHEL use rpm, others use yum, and then all Debian based distros use apt-get. – Linuxios Sep 17 '12 at 13:21
    
Can you publish the output of /etc/issue, /etc/release, /etc/version, /etc/release-version ? (may be not all of them exist). This provides information about what linux distribution is installed on this particular machine an would help to find an answer to your issue. – jhcaiced Sep 17 '12 at 15:09
up vote 1 down vote accepted

Do you have links or curl? Do you have ssh? Then you have scp, you can transfer for example a tar.gz source file to it and see if you have make and gcc, and build/compile the package on the machine, then set the prefix to somewhere under your home folder and install the package there. You could download and install pacman - then you have a packet manager!

To check the version of the distro usually its in /etc/release or /etc/version or /etc/release-version

But it seems to be an old RedHat machine, so you probably only have rpm. So then use scp to transfer a .rpm package to it (which sutis the redhat version) and install it with rpm -U something. Probably look into scp'ing in a wget .rpm package, after that the rpm should work better.

share|improve this answer
    
Yes, I have curl, ssh and scp. Guess I'd better try getting source codes and makeing things... thanks for your advice :) – e9t Sep 18 '12 at 11:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .