Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The problem

After partially entering a URL like meta.st, Chrome adds in the rest of the URL highlighted in blue and says "Press Tab to search Meta Stack Overflow". But on pressing, instead of showing a blue box and allowing us to search on that site, it just moves the cursor to the next item like in a normal text-field.

Other info

I'm on Windows 7 Home Basic. My Chrome version number is 22.0.1229.52 beta-m (beta channel). This was working before.

What I've tried

I've reported it in Chrome (by going to Options > Tools > Report an issue...). I've also tried deleting all my custom search engines (they might've been interfering) and also tried creating a new profile. I also googled, but to no avail.

How do I fix this? Thanks.

share|improve this question
    
> After partially entering a URL like meta.st Does it show the rest of the URL in the Omnibar? It should show the part you type in white and the rest (the part it predicts you will type) in blue, i.e., selected (these are the default colors in Windows, yours may vary, but the point is that it should automatically fill in the rest of the URL as selected text). –  Synetech Sep 18 '12 at 4:28
    
Unfortunately that is still true and weeding out the innumerable unnecessary/unwanted keywords quickly becomes a futile task. –  Synetech Sep 18 '12 at 6:49
    
@Synetech I didn't understand what you meant by "Unfortunately that is still true and weeding out the innumerable unnecessary/unwanted keywords quickly becomes a futile task" –  YatharthROCK Sep 18 '12 at 15:29
    
@YatharthROCK, Chrome is designed so that every time you use a search box in any site, it gets added as a custom search engine. This is useful for sites you visit frequently, but it also adds a lot of clutter because sites that you may have visited only once also get added. Worse, ever since they did away with tabbed-options and made the settings all-HTML, it is a lot of work to delete all the once that you never use. –  Synetech Sep 18 '12 at 18:02
    
@YatharthROCK, so does it show the rest of the URL or not? If it does, then there may be a bug in the version you are using. If it does not, then you may have multiple URLs/domains that are almost identical and you have to type a few more characters before it will work as expected. –  Synetech Sep 18 '12 at 18:03
show 1 more comment

1 Answer 1

up vote 2 down vote accepted

The problem went away on it's own. Everything is working as expected. As a side note, they also changed the UI of the prompt that comes up.

As @HumanBlade postulated, it was probably just a bug or regression. I guess such things are to be expected if you're using the Beta or Dev channel.

Anyway, considering Chrome is self-updating, this question is probably too localized and will get closed very soon. Cheers till then :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.