Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed OS X Mountain Lion as a VM in VMware Fusion (version 4.1.2) for environment testing. The host OS is OS X 10.7.4, and is connected to the internet via a wired connection (in fact I get the same problem if it is connected via wireless as well).

As long as VMware Fusion is running, my internet for the Host OS stops working, but remains functional inside the VM.

I am using NAT for VMware Fusion.

For additional testing, I have an Ubuntu box on Virtual Box. When VMware Fusion is off, I have internet on both my host OS and the Ubuntu VM, and when VMware fusion is running, I have no internet connection except inside VMware Fusion.

VMware Fusion blocks internet even if the actual VM is suspended.

share|improve this question
add comment

2 Answers 2

You have likely set your VM to use the same IP address as your host machine. This article talks about it. If both are using the same address, any traffic destined to the IP address of the network adapter used by the host OS will be passed to the VM.

Simplest solution is to ensure everyone has their own IP address (the Host machine has one, and the VM has one that is on the same network).

This article walks you through reconfiguring the virtual network adapter. The part you need is quoted here:

To change the configuration of an existing virtual network adapter, follow these steps.

  1. Open the virtual machine settings editor (VM > Settings).

  2. Select the adapter you want to modify.

  3. Select the network type you want to use — Bridged, NAT, Host-only or Custom.

  4. If you select Custom, choose the VMnet virtual network you want to use for the network from the drop-down list.

  5. Click OK to save your changes and close the virtual machine settings editor.

  6. Be sure the guest operating system is configured to use an appropriate IP address on the new network. If the guest is using DHCP, release and renew the lease. If the IP address is set statically, be sure the guest has an address on the correct virtual network.

Item 6 is likely to be what you need to focus on. Remember to make sure the IP address for the VM isn't in use elsewhere in the network.

share|improve this answer
    
Unfortunately, this is not a valid solution, because if there is no VM running, there cannot be an IP conflict. –  Glen Solsberry Oct 29 '12 at 15:19
    
Where in what you said, or what I said, did anyone say anything about a Virtual MAchine not running? I'm afraid I have no idea what you're talking about? –  Everett Nov 8 '12 at 4:06
    
From the original question "VMware Fusion blocks internet even if the actual VM is suspended.". –  Glen Solsberry Nov 8 '12 at 13:54
    
Just because you suspend the VM, that does NOT mean that the VM software is going to release the control of the network adapter. I know this fact from experience. Why don't you try this before you convince yourself a potential answer isn't going to work? Notice the changes are being made in the VM software, NOT on the virtual machine. –  Everett Nov 9 '12 at 2:41
add comment

I ran into this problem on OS X Mavericks 10.9.1 and VMWare Fusion 6.0.2. My solution to fixing this was to remove the folder /Library/Preferences/VMWare Fusion/ so that VMWare would perform its one time setup again.

You may want to make a backup of this folder before removing it, just in case.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.