Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How can I make an MSI installer run in English?

I'm trying to install LibreOffice on a machine running a Korean version of Windows XP. I don't know Korean. I haven't used Windows with any frequency in many years, so I'm pretty lost.

When I run the installer, it shows up in Korean. But, I want to customize the installation, so I need the installer to be in English. Googling took me to this page, where I found an example command to run the installer in Gaelic, which I modified for my system as follows:

msiexec /i LibO_3.6.1_Win_x86_install_multi.msi TRANSFORMS=:1084

This works, except that I know less about Gaelic than I do about Korean. The help page provided a link to a page where I could look up the ID codes. From that page, I determined that the correct code was 1033 for US English and 2057 for UK English. When I substituted the code, I got an error message. Here's the messages as translated by Google, followed by the original:

Transform can not be applied. Verify that the specified transform paths are valid.

변환 내용을 적용할 수 없습니다. 지정한 변환 경로가 올바른지 확인십시오.

I can't very well search on a machine translation, so I don't know where to go from here.

  1. What is the problem?
  2. How can I make the installer operate in English?
  3. Alternatively, how can I change XP to display its interface in English, while keeping full functionality for typing in Korean?
share|improve this question
    
Just got a tumbleweed for this. Doesn't anybody know about this? –  Scott Severance Sep 25 '12 at 7:23
add comment

1 Answer 1

  1. Your problem is that the (English) messages you want to see are not present in the binaries, neither the Windows Installer program itself or the .msi file, available at your target machine. The "solution" for Gaelic was a kludge which added (through the transform) to the .msi file the Gaelic strings, since these are not widely available; unfortunately, the LibreOffice developers apparently did not take the time to prepare a similar English transform.

  2. AFAIK, Windows Installer for Windows XP is fully localized, which means that all the text are translated to the target language, Korean in your case. A bad solution could be to force the reinstall the English variant of the last version of Windows Installer; this will require cheating at it to make it believe it is installing on English XP, something which is not trivial, and which could lead to subtle problems later because the installer will blindly assume the target for future .msi installations is to an English XP.

  3. You need to install the English version of XP, then install Korean as a supplementary language in the Regional Settings control panel; be sure to visit all the corners of the panel, since you will need to enable Korean as a system language (thus installing the required fonts) and the keyboard layout also named input locale. Unfortunately this requires to reinstall from scratch, upgrading is not an option; also check your license.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.