Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install mod_python 3.3.1 on Apache 2.4.3 and whenever I try to run ./configure (with apxs etc), instead of configuring correctly, it says that Apache 2.x is required and my current version is .

I've tried on two different versions of Apache, and too different versions of mod_python but always with the same result. I am running as root on a FreeBSD system. Any suggestions?

\# ./configure --with-apxs=/wwwroot/bin/apxs
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for ar... ar
checking for a BSD-compatible install... /usr/bin/install -c
checking whether make sets $(MAKE)... yes
checking for main in -lm... yes
checking for an ANSI C-conforming const... yes
checking your blood pressure... a bit high, but we can proceed
configure: checking whether apxs is available...
checking for --with-apxs... /wwwroot/bin/apxs executable, good
checking Apache version... ./configure.lineno: /wwwroot/bin/apxs: not found
./configure.lineno: /wwwroot/bin/apxs: not found
./configure.lineno: /: permission denied

configure: error: This version of mod_python only works with Apache 2. The one you have seems to be .
share|improve this question
To me it looks like it doesn't find apache on the system... so its not . its just blank. Can you confirm your apache install was successful? – VenomFangs Sep 22 '15 at 22:44

You must log in to answer this question.

Browse other questions tagged .