Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Everytime I press the F11 key it opens up a browser window with the same URL. This happens anywhere I press it and I need this key to have it's default behavior because I use it to program on Visual Studio (Windows 7).

Any ideas why this is happening and how to go back to default function keys?, I haven't installed anything that I remember can cause this behavior.

This is a standard Dell desktop key board, no multimedia keys, like this one:

enter image description here

Firing URL is http://argos:8080/Login.jsp?jsessionid=55rh3obsahm9m

seems like one of our company's internal addresses but IT guys say they have no idea about it.

I don't see any suspicious software that can be causing this.

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

Check the Keyboard applet in Control Panel, as well as any other CP applet that looks as if it might be keyboard/input device-related, as well as your installed programs list. There must be something extraneous that's causing this, since it's not default Windows behaviour. Also, what's the URL? Maybe that'll help track the software down.

share|improve this answer
    
hey @Karan, see my question update –  Milox Sep 18 '12 at 21:30
    
Yeah, knowing the URL didn't help (it probably refers to an installation of this on your intranet). What about Control Panel and your Add/Remove Programs list? Did you check those to see what 3rd party software is installed? Because something is and that's what is setting a global hotkey for F11. BTW, can you also check what your browser's home page is set to? It's possible the key is simply calling up your browser, which in turn is opening up its home page URL. –  Karan Sep 18 '12 at 21:47
    
No home page on my browser but you were absolutely right I checked my programs list and sorted it by installation date, then I noticed IT guys installed me Microsoft RichCopy the last week, remove it and I got back my F11 key, thanks for insisting @Karan –  Milox Sep 20 '12 at 21:19
    
You're welcome, glad you figured it out. BTW, RichCopy should have an option to de-register any global hotkeys it sets, but I'm not sure. Just something to look into if you ever do need it to be re-installed. –  Karan Sep 20 '12 at 21:28
add comment

Have you got an FN-toggle button on your keyboard? This sounds like you have one of the media keyboards with Mail and such bound to alternative uses of the Function keys.

Try hitting that button, if you have it, and if that is the problem it will be sorted.

share|improve this answer
    
Hey note that on some keyboards you have to hold the button for default behavior while on other keyboards that button can toggle between normal and shortcut behavior. –  Itay Grudev Sep 18 '12 at 15:50
    
Ouch, I've not encountered that kind of keyboard. I guess it's not targeted at me, it just sounds bad for my usage. –  Jeeva Sep 18 '12 at 15:56
    
nope, this is a standard desktop keyboard, FN-toggle button –  Milox Sep 18 '12 at 16:08
    
Hm, okay. Thanks for image / response. –  Jeeva Sep 18 '12 at 16:22
    
In this case I guess that this is a software problem. Do you have any Hotkey software or driver installed? –  Itay Grudev Sep 18 '12 at 16:25
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.