Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Occasionally while I work, without any special provocation, I lose connectivity via Wi-Fi. Other devices connected to the same wifi network have no interruption, and the problem gets resolved once I reboot, so it's definitely a local problem.

Observations:

  • The Wi-Fi symbol in the menu indicates that I'm still connected, but apps can't actually connect neither to the Internet nor to other devices in the LAN.
  • I can't connect to an alternate Wi-Fi network (e.g. Wi-Fi tethering via iPhone).
  • I can connect to the Internet via iPhone USB tethering but this seems to only work some of the time.
  • Only a reboot solves the problem but a regular restart gets stuck on a grey screen with rotating wheel (after all applications have closed) and I have to do a hard reset.

I'm on a MacBook Air mid '11 running 10.8.1.

How should I go about troubleshooting this? It used to happen very rarely but now is becoming more frequent (approaching once every 2-3 days on average).

share|improve this question
    
Have you done any research on this? OSXDaily.com has a number of ways to troubleshoot wireless problems on OS X. Failing that, you could have bad hardware. –  user3463 Sep 18 '12 at 16:49
    
Which OSX version are you on? Have you installed the latest updates? There have been several complaints about droping wifi signals in Lion that were said to be repaired in OS updates. –  Vincent Sep 18 '12 at 20:54
    
What do the logs say? –  Spiff Sep 19 '12 at 3:12
    
@Spiff the system.log has many lines in the minutes before the reboot, most of them seem to me irrelevant. Is there any specific process / keyword I should be looking for? –  GJ. Sep 19 '12 at 4:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.