Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My network adapter is set to "Bridged Adapter". My CentOS (guest) IP is 192.168.0.4 and I am able to view Apache web server (port 80) from Windows 7 (host) but I am unable to SSH (port 22). I get "connection refused" from putty.

Here's a screenshot of my iptables in CentOS:

enter image description here

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

If you are accessing the Apache HTTP Server welcome page using localhost and not the IP address, then it is possible that dhcpcd is not running. Have you verified that sshd is running?

share|improve this answer
    
Wow I think I better go to sleep sshd was simply not running. LOL. –  IMB Sep 18 '12 at 20:23
    
Haha, it happens to the best of us. –  p_strand Sep 18 '12 at 20:26
add comment

First make sure you can connect to the CentOS VB

ping 192.168.0.4

  • Make sure sshd is running, the "connection refused message" usually means that sshd is not running.
/etc/init.d/sshd restart
  • Your firewall configuration appears to be ok, but just in case disable it for testing.
/etc/init.d/iptables stop
  • Also check your configuration in /etc/hosts.allow and /etc/hosts.deny, at least must have a line like:

sshd : 192.168.0. : allow

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.