Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
direct ethernet connection between two wirelessly connected Windows 7 laptops

I'm running two PCs, a desktop and a laptop with Windows 8 Release Preview ("Build 8400").

They are connected to the same router in infrastructure mode, thereby having wireless internet. Due to often file synchronization between the machines I want to establish a cable connection that allows direct file transfer, without needing to use the wireless. When I plug in the cable (normal, not cross-over), I see in "Control Panel\Network and Internet\Network Connections": "Ethernet - unidentified Network" on both PCs. Transferring a file between both still only uses the WiFi via the Router.

I noticed that when turning off the wifi on one PC, I can set up a shared internet connection that will work via Ethernet-cable, but since sometimes only one PC runs, sometimes the other one, I do not want to have the internet of one machine to be dependent on the other one being switched on.

I do not have a crossover-cable, but since I did connect the PCs already successfully (just without both being on the internet), I'm sure that this should also work with a normal ethernet cable.

share|improve this question

marked as duplicate by Journeyman Geek, Indrek, 8088, avirk, BBlake Sep 20 '12 at 18:26

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
You should tell us your router&switch manufacturer/model. YOu do not have to share internet connection (ICS) if all computers are connected to your router/switch directly. All computers are using win8? All on the same workgroup? All same ip subnet range? –  Logman Sep 18 '12 at 21:17
    
The router is D-Link DIR-652. Both computers are running Win8, and are all in the same workgroup. I have set the IPs to 192.168.0.1 and .0.2 for the two PCs. I just tried to connect the ethernet cable while both pcs are running; now I cannot open any new websites since firefox seems not to have internet connection, but skype and jdownloader still work. Only a complete restart makes everything work again. –  Marie. P. Sep 18 '12 at 21:50
    
It's not clear -- are you plugging a single cable into both computers, or two cables from computers to router? Generally, a single non-crossover cable will not work at all. You need to have some sort of hub (which the router can be) or use a crossover cable. (Note that you only need a short crossover and a coupler, plus whatever longer cable you have that will reach between the two, if they are some distance apart.) But with the crossover or a dumb hub you'll have to manually set the IP addresses for the cable connections. –  Daniel R Hicks Sep 18 '12 at 22:31
    
I plug a single cable from one computer to another. I actually read everywhere that nowadays the software will immediately recognize if the cable should be used in crossover-mode, so I wouldn't think that was a crossover was necessary? –  Marie. P. Sep 18 '12 at 22:37
    
@DanielRHicks Gigabit ethernet, which is standard nowadays, mandates Auto-MDI/X, which means that it doesn't matter if you use a crossover cable or not. –  Stefan Seidel Sep 19 '12 at 12:32

2 Answers 2

up vote 2 down vote accepted

You computers both have two network interfaces, the WiFi and the Ethernet. You already mentioned that you have set the WiFi to automatic (DHCP) addresses and the Ethernet connection to manual IP addresses, which is good.

Now you need to make sure that the IP address ranges from those network interfaces do not overlap. You can easily accomplish this by setting your Ethernet cable connection IP addresses to a not-so-commonly used range like 10.34.0.1 on one computer and 10.34.0.2 on the other (subnet mask 255.255.255.0). Then you must change the network profile to "Home or Work" in order to make Windows accept connections between the tho computers.

Finally, you should then be able to access the other computer solely via Ethernet by using the IP address. In the explorer's address bar or in the start menu input line, just enter \\10.34.0.1 to view the other computer's shared files.

share|improve this answer
    
Now it all works! –  Marie. P. Sep 24 '12 at 9:04

The default IP for your router is 192.168.0.1 You mentioned you have one of your computers set to that IP. You should have your computers set to auto configure or change that computer that has 192.168.0.1 to something greater. Unless you changed your router address. Normally routers are set to x.x.x.1

You can access your router with a browser:

IP ADDRESS:    http://dlinkrouter or http://192.168.0.1
USERNAME:     admin
PASSWORD:

Change your router password right away. Those are the defaults. If you cannot logon, reset your router to defaults:

HOW DO I RESET MY DIR-652 ROUTER TO FACTORY DEFAULT SETTINGS? - Ensure the router is powered on. - Press and hold the reset button on the rear of the device for 20 seconds. Note: Resetting the router to factory default will erase the current configuration settings. To reconfigure your settings, log into the router as outlined in question 1, then run the Setup Wizard.

..maybe...

WHY CAN I NOT GET AN INTERNET CONNECTION? - For Cable users make sure Clone MAC address option is ticked during Wizard installation (or enter the registered MAC) and make sure the service has been enabled/connected and is operational.

share|improve this answer
    
alright, I know change the computers' IPs to .2 and .3. Now, if I plug in the cable, I still have a working wireless at least. But when I try to access one PC from the other (e.g. Network\PC-NAME\Users\Desktop), the connection is set up via wireless (as I can check by turning off the wireless while copying). Then when I try to copy something large, it takes hours and the explorer freezes a few times. Is there a way to force the use of the ethernet connection? By the way, I'm still seeing the connection as an "unidentified public network", and I don't see any options to change that. –  Marie. P. Sep 18 '12 at 22:45
    
"unidentified public network"- can be several things. Do you still have the TCP/IP settings set manually? or Auto? on wireless & wired? Do you have the correct gateway set?or not set? My understanding is that you cannot have both wired & wireless using a gateway. Only one can be used for internet (gateway set for wireless only and blank for wired, this allows wired for local file transfer). Though I am not familiar with win8... –  Logman Sep 19 '12 at 0:29
    
The TCP/IP-settings are auto on both computers for the wireless network, and for the ethernet, the IPs are 192.168.0.2/3, the subnet mask is 255.255.255.0, and the default gateway and DNS server adress are left blank. –  Marie. P. Sep 19 '12 at 7:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.