Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently built a new computer (running Win7 Pro 64-bit) that includes the Microsoft Sidewinder X4 Keyboard. To make use of all the extra features of this keyboard I need the Mouse and Keyboard Center. I just ran Windows Update for the first time on this system and the Mouse and Keyboard Center was included in the update.

I'm left-handed and before the update I had the mouse set up for lefty use. Now after the update, it's been set to righty use and the original mouse control panel applet no longer allows the assignment of buttons. For that there's a link to the Mouse and Keyboard Center which does not support my oldish mice. (I have an IntelliMouse Optical and a Creative Mouse Lite Pro.)

So I need the new utility for my keyboard, but I have to be right-handed to use my mouse? Really!

I tried changing HKCU\Control Panel\Mouse\SwapMouseButtons to 1, but a reboot set it back to 0. Is there some way I can change my mouse back to left-handed?

Thanx -eljay

share|improve this question

3 Answers 3

Hi I had the same problem and I uninstalled Microsoft Mouse and Keyboard Center and installed Microsoft IntelliType Pro 8.2

Now I can assign all macros to my keyboard and mouse settings are not affected.

share|improve this answer

Rather than uninstalling Microsoft Mouse and Keyboard Center, disabling IPoint.exe in startup worked for me.

  1. Press Win-R to open the Run dialog and type 'msconfig' (without quotes).
  2. When MSConfig loads, click the Startup tab.
  3. Locate the items that read 'Microsoft Mouse and Keyboard Center' in the Startup Item column.
  4. Scroll right to the Command column and expand it so you can read the complete column values.
  5. Look for the item that ends with 'ipoint.exe' and uncheck that item in the Startup Item column.
  6. Click Ok to accept.
  7. regedit and set HKCU\Control Panel\Mouse\SwapMouseButtons to 1.
  8. Reboot
share|improve this answer
    
Doesn't work for me. As you can see from the question, even your first step will fail. If I could switch mouse buttons the way I want, I'll be happy and will not need this at all. Killing "ipoint" or disabling it in "startup" doesn't do the trick. –  Andrey Regentov Feb 2 '13 at 14:21
    
Realized the way. After turning "ipoint" out I should swap buttons through regedit. Edited your answer accordingly. –  Andrey Regentov Feb 2 '13 at 14:52
    
Oh god! And regedit/reboot every time I run "Microsoft Mouse and Keyboard Center". Uninstall app and forget this nightmare! –  Andrey Regentov Feb 2 '13 at 14:56

I had the same issue, I've uninstalled the "mouse and keyboard center" app and I got the previous mouse configuration which has this functionality

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.