Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to get my Atheros AR1111 EB-WG PCI wireless adapter to work. Right now wifi is not even detected. I'm on ubuntu 12.04 64bit and I managed to find a xp64bit driver. I followed the exact steps here: https://help.ubuntu.com/community/WifiDocs/Driver/Ndiswrapper

And where I do:

 ndiswrapper -l

I get something like :

 {name of driver} : driver installed
       device ({Chipset ID}) present

which shows that the driver installed properly

However, after I load the new module :

  sudo modprobe ndiswrapper

nothing happens, and iwconfig shows that I still have no wlan.

I tried to do dmseg | grep ndiswrapper, but there were no driver loading errors or anything strange.

I also have blacklist ath5k, ath8k in /etc/modprobe.d/blacklist.conf

What am I doing wrong? What could be causing this?

share|improve this question
    
I had exactly the same problem with TRENDnet TEW-424UB. driver installed, ndiswrapper module loaded but nothing happens! so what i did is just pulling the USB dongle out and back in again. voilia it works!! maybe this will help somebody. you can read more about how i did it here wirelessmania.blogspot.ch/2013/11/… –  user277069 Nov 26 '13 at 12:11

1 Answer 1

ndiswrapper is inherently flawed, and will always be incompatible with the vast majority of WiFi drivers out there. Internally, it uses a form of emulation similar to wine does for general userspace applications. It is an imperfect science because of the varying semantics and function call usage of NDIS device drivers, and because ndiswrapper historically has only implemented support for function calls that are absolutely required for drivers that were targeted for support, i.e. the bare minimum. So a lot of function calls are still not implemented, and may not be implementable due to the design of the Linux kernel networking stack.

You're likely not doing anything "wrong", except that I think you need to load ndiswrapper kernel module first, then run ndiswrapper -l. But if you aren't getting the interface, then it's just not working. This is pretty much the norm for ndiswrapper.

Like wine, individual driver versions for individual wireless cards have to be specifically "targeted", and development teams (volunteer or commercial) have to analyze the driver's NDIS calls and determine how to modify ndiswrapper to support said driver. This is a standard development methodology for emulation layers, since implementing an entire emulation layer is very labor-intensive and will come chock-full of bugs out of the box anyway, due to semantic mismatches, layering mismatches, and so on.

You should search harder for the existence of an open source, native driver for your chipset. Failing that, you are probably out of luck. ndiswrapper is not a solution; it's a temporary placeholder to give a small subset of users with unusual chipsets basic wireless functionality until an open source driver can be written. Don't rely on it; don't expect it to work; insist on a native driver or just flat-out replace your hardware with something that is supported out of the box. Sorry.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.