Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just updated to the stable version of Cinnamon 1.6 in Ubuntu 12.04 x64, but I found a bug which just get's me out of my skin.

The key combination CtrlAltT which is supposed to open up the Terminal doesn't work.

Any ideas?

P.S. I would really like to stick with the same shortcut.

share|improve this question
add comment

2 Answers

up vote 4 down vote accepted

You could try creating a custom shortcut for terminal with Ctrl-Alt-T as the assigned keyboard shortcut.

Open keyboard from Menu and move to Custom Shortcuts. Add a new shortcut by clicking on the + button. Add a relevant name to the shortcut. Input gnome-terminal or Linux Mint alternative command and add the keyboard shortcut you desire.

Keyboard shortcuts


See my answer on Ask Ubuntu for reference:

share|improve this answer
    
Thanks a lot! I haven't thought about that one... –  Itay Grudev Sep 20 '12 at 7:58
add comment

I had a similar problem and found a solution. The distribution I've got is Linux Mint w/ Cinnamon GUI, which is offered as Debian-based or as Ubuntu-based versions. Mine's the Debian-based version, identified as 201303 presumably for March 2013, at a time when the Ubuntu-based version is named 16 Petra.

Clicking my way through menus starting at the taskbar (or whatever it's called in Cinnamon)...

Preferences -> Cinnamon Settings -> Keyboard

Here I went to put a Terminal shortcut, to use Ctrl-Alt-t for the terminal, but I see it's already there in the list from a fresh installation. Yet Ctrl-Alt-t doesn't do anything when I type it. Odd. So that's a dead end.

Going into the file manager worked. Navigate your directories to here:

/usr/share/applications/

and double-click the "keyboard" program in there. You cannot open the program from the command line, you have to be in a graphical file manager. If you were to try opening it from a terminal, you'd first realize the actual name of it is gnome-keyboard.desktop. There's a help page discussing how .desktop files can't be opened via a terminal: http://askubuntu.com/questions/5172/running-a-desktop-file-in-the-terminal

Anyway, once you've double-clicked it and opened it, entering your settings there works. In the left sidebar, click on "Custom Shortcuts", then click on the + sign. In the text field for Name, put Terminal or whatever you want -- the name doesn't matter. In the text field for Command, put x-terminal-emulator. Don't have a period after it, I was just ending my sentence.

Lastly, on the right side of the window is the word Disabled. Do a single click on that word (not just anywhere on the line) and it'll change to New Shortcut, at which point you can hold down the Ctrl and Alt keys and hit the letter t, to input the Ctrl-Alt-t shortcut. If nothing seems to happen, be advised that accidentally doing a double-click instead of a single click toggles it so quickly (from Disabled to New Shortcut back to Disabled), you'd be forgiven for thinking your input was ignored.

Now try using your shortcut. For me it goes into effect before even quitting the program.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.