Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How can Windows be configured NOT to group several printers under one printer - shown as one item in Printers and Faxes in Control Panel\Hardware and Sound\Devices and Printers?

Background

Reason for question:

I am using a label editing program that stores the printer model in the label file. I need to support several printers to print the label so I create a file for each printer. However, I only have one printer model at my desk and I just need to test print the labels for all models on this printer even though I don't have all of the models on my desk. But I can't get the label to print, so I suspect it is something to do with how the printers are being grouped.

My colleagues' machines have the same setup and they can print successfully all labels, but on their machines, Windows 7 does not group the printers under one item, each different printer model is shown as a separate item.

Research

I have tried looking here but no conclusive solution: http://social.technet.microsoft.com/Forums/en/w7itproui/thread/cf1148ac-17f0-4783-9aa9-34216377b597

share|improve this question
    
You can add multiple 'Printers' but all with the same destination Port/IP address etc. I do it here, default printer is a network printer, grey scale, high compression, medium quality and double sided (to lower toner use, increase speed and reduce paper use). I have another printer installed (same printer, IP & driver) with the opposite settings for photo printing. –  HaydnWVN Sep 19 '12 at 11:55
    
That's exactly what I did, but then Windows decided to group them under one item following a reboot. –  therobyouknow Sep 19 '12 at 12:09
    
I assume you have looked at the "view" settings for printers and devices? –  Moab Sep 19 '12 at 14:35
    
Does each printer have its own individual entry in the classic "Printers" folder? You can open that folder by entering start shell:::{26EE0668-A00A-44D7-9371-BEB064C98683}\0\::{2227A280-3AEA-1069-A2DE-0800‌​2B30309D} in a command prompt. –  Josh Townzen Sep 19 '12 at 23:15
    
@JoshTownzen that doesn't work here (Win7 Pro 32bit) –  HaydnWVN Sep 20 '12 at 7:38

1 Answer 1

You will have to create a new port with the printer settings, but make sure the port name is different. If the port names are the same it will group them, changing the port name will solve your issue.

share|improve this answer
    
Thanks I'll consider that and report back. –  therobyouknow Sep 19 '12 at 14:48
    
More information here and the link you mentioned in the question here gives information about changing the port name to work around the issue. –  HaydnWVN Sep 20 '12 at 7:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.