Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Some packages have gone missing from my Ubuntu server and few things are not working because of that.

When I try to install mysql-client I get this error:

# sudo apt-get install mysql-client-5.1
Reading package lists... Done
Building dependency tree       
Reading state information... Done

You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libauthen-pam-perl : Depends: perlapi-5.14.2
 libdbi-perl : Depends: perlapi-5.14.2
 libio-pty-perl : Depends: perlapi-5.14.2
 libnet-ssleay-perl : Depends: perlapi-5.14.2
 libperl5.14 : Depends: perl-base (= 5.14.2-13) but 5.10.1-8ubuntu2 is to be installed
 libsub-name-perl : Depends: perlapi-5.14.2
 libtext-charwidth-perl : Depends: perl-base (>= 5.14.2-3) but 5.10.1-8ubuntu2 is to be installed
                          Depends: perlapi-5.14.2
 libtext-iconv-perl : Depends: perl-base (>= 5.14.2-5) but 5.10.1-8ubuntu2 is to be installed
                      Depends: perlapi-5.14.2
 mysql-client : Depends: mysql-client-5.5 but it is not going to be installed
 mysql-client-5.1 : Depends: mysql-common (>= 5.1.63-0ubuntu0.10.04.1) but 5.1.41-3ubuntu12 is to be installed
                    Depends: libmysqlclient16 (>= 5.1.63-0ubuntu0.10.04.1) but 5.1.41-3ubuntu12 is to be installed
                    Depends: mysql-client-core-5.1 (>= 5.1.63-0ubuntu0.10.04.1) but 5.1.41-3ubuntu12 is to be installed
 perl : Depends: perl-base (= 5.14.2-13) but 5.10.1-8ubuntu2 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

When I run apt-get -f install get following error.

The following packages will be REMOVED:
  mysql-server-5.1 mysql-server-core-5.1
The following NEW packages will be installed:
  libmysqlclient18 mysql-client-5.5 mysql-server-5.5 mysql-server-core-5.5
The following packages will be upgraded:
  ifupdown initscripts libdbd-mysql-perl liblocale-gettext-perl mysql-common mysql-server netbase perl-base rsyslog
9 upgraded, 4 newly installed, 2 to remove and 172 not upgraded.
15 not fully installed or removed.
Need to get 0 B/10.7 MB of archives.
After this operation, 64.8 MB of additional disk space will be used.
Do you want to continue [Y/n]? Y
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LC_CTYPE = "UTF-8",
    LANG = (unset)
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
/usr/bin/perl: symbol lookup error: /usr/lib/perl5/auto/Text/Iconv/Iconv.so: undefined symbol: Perl_xs_apiversion_bootcheck
(Reading database ... 43650 files and directories currently installed.)
Unpacking mysql-client-5.5 (from .../mysql-client-5.5_5.5.24+dfsg-8_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/mysql-client-5.5_5.5.24+dfsg-8_amd64.deb (--unpack):
 trying to overwrite '/usr/bin/mysqlcheck', which is also in package mysql-client-core-5.1 5.1.41-3ubuntu12
configured to not write apport reports
                                      dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/mysql-client-5.5_5.5.24+dfsg-8_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
share|improve this question
1  
Did you try apt-get -f install? – m4573r Sep 19 '12 at 13:28
    
@m4573r yes, i updated the answer error message i get when I run apt-get -f install – Sharj Sep 19 '12 at 13:37
    
try install localepurge. it should run immediately after install and you can select the languages you want to be available on the system. it looks like some are missing. – d4v3y0rk Sep 19 '12 at 14:18
1  
also have you recently changes your sources.list file? – d4v3y0rk Sep 19 '12 at 14:20
    
I didn't change that and installing localepurge also gives error. # sudo apt-get install localepurge Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: mysql-server-5.1 : Depends: mysql-client-5.1 (>= 5.1.41-3ubuntu12) but it is not going to be installed E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution). – Sharj Sep 19 '12 at 14:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.