Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So I have just recently bought and 8GB USB stick(Kingston DT 100 G2) on which I had installed Linux. However I needed to reinstall said Linux so I formatted the stick to "default" settings which includes FAT32 filesystem.

Later when the install process kept getting errors, I got advice that the problem might be with the FAT filesystem. I decided to try and format the stick to NTSF (format G:/fs:ntsf) but the formatting failed and the drive broke down.

And with breaking down I mean you cannot access the drive anymore and when you plug it in Windows asks if I want to format the drive but despite my will the format always fails.

To fix this I tried changing it back to FAT32 (format G:/fs:fat32), but i get "Error in IOCTL-call". Second thing I tried was trying to reset the filesystem with some 3rd party application like HP USB Disk Storage Format Tool. But the programs didn´t regocnize any media on the drive.

So now I´m in the situation that I haven´t got any idea on what to do next. Is the drive recoverable or did I just create a piece of waste metal.

share|improve this question
up vote 2 down vote accepted

First, go to disk management under the device manager in Windows. Does the USB stick show up? If so, try removing the partition, then create a new one.

If that doesnt work, try creating and booting off a Gnome Partition Editor livecd to erase/format the disk. It may be able to accomplish more than Windows disk management is able to.

share|improve this answer
    
Yeah it seems it´s fried. Went to the device manager and it just showed a grey bar where the partitions should´ve been. And when i got the Gparted it didn´t even regocnize the stick. So I quess i´ll have to buy a new one. – Dmolish Sep 19 '12 at 15:55
    
try Gnome Partition Editor, you have nothing to lose – Keltari Sep 19 '12 at 15:56
    
Yea I tried that but, as I edited to my earlier post, it didn´t even regocnize the stick. – Dmolish Sep 19 '12 at 15:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .