Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running Ubuntu Jaunty. I have been using Seamonkey for mail and as a simple HTML editor. For no reason I can figure out, in my personal account on my laptop, it now fails to start. If I start it from the command line, no messages are printed, it just exits. I ran it within strace and got this:

open("/usr/lib/xulrunner/components/xpti.dat.tmp", O_WRONLY|O_CREAT|O_TRUNC|O_LARGEFILE, 0666) = -1 EACCES (Permission denied) gettimeofday({1254104570, 451853}, NULL) = 0 stat64("/usr/lib/xulrunner/components/compreg.dat", 0xbfb2bbf4) = -1 ENOENT (No such file or directory) lstat64("/usr/lib/xulrunner/components/compreg.dat", 0xbfb2bbf4) = -1 ENOENT (No such file or directory) access("/usr/lib/xulrunner/xpicleanup.dat", F_OK) = -1 ENOENT (No such file or directory) pipe([6, 7]) = 0 fcntl64(6, F_GETFL) = 0 (flags O_RDONLY) fcntl64(6, F_SETFL, O_RDONLY|O_NONBLOCK) = 0 fcntl64(7, F_GETFL) = 0x1 (flags O_WRONLY) fcntl64(7, F_SETFL, O_WRONLY|O_NONBLOCK) = 0 read(6, 0xbfb2bcd3, 1) = -1 EAGAIN (Resource temporarily unavailable) close(6) = 0 close(7) = 0 exit_group(1) = ?

This is of course only the last few lines.

I discovered that I can still run Seamonkey either as root, or as another normal user on this system, but when I use my personal account, it just exits.

I have tried purging seamonkey and the xul libraries and reinstalling. This had no effect.

I conclude that there's something weird about the configuration for this account. However, even if I rename the .mozilla directory, seamonkey exits when run as me, but works fine when run as root or testmonkey (my testing account). It's very strange.

I would be very grateful for any help.

share|improve this question
up vote 1 down vote accepted

I ended up installing the second beta of SeaMonkey 2, which starts up for my main account. So I never actually identified the problem, but I did "solve" it.

If you're using Debian/Ubuntu/Knoppix/etc. you can find debs for the beta here:

share|improve this answer

From SeamMonkey Installation

Multi-User Linux Installations To install SeaMonkey for multiple users on Unix, install as normal, then create the following script in your SeaMonkey directory, make it executable (chmod u+x ), and run it as a user with write privileges to the mozilla directory (e.g. root). Do not run this program as su[do] root. (Bug 52653)

dist_bin=`dirname $0`
touch $dist_bin/chrome/user-skins.rdf $dist_bin/chrome/user-locales.rdf

You should then be able to run that installation of SeaMonkey as any user who has permissions to access it.

share|improve this answer
What is the "Seamonkey directory"? /var/lib/seamonkey? In any case, this script doesn't work and at least one file involved (regxpcom) does not exist. I do appreciate the effort, though. – CarlF Sep 28 '09 at 21:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .