Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Windows Update tried to install some updates and now it wants to reboot. But I'm doing some work that I'd rather not interrupt for the time being. To shut up the nagging reminders about rebooting, I went into Services and Stopped the Windows Update service.

A few hours later, I got another reminder. I went in to Services again, and Windows Update was running again! So I said Stop again. And now it happened again.

I will reboot when I'm ready to, and until that happens, I want this service to go down and stay down. What could be restarting it without my knowledge, and how do I make it stop?

share|improve this question
up vote 1 down vote accepted

Those notifications aren't coming from the service itself, they're coming from the client. The "remind me later" option just minimizes the client to the notification area, it doesn't make the client exit.

If you stop the service and then kill the instance of wuauclt.exe that's running in your user context the notifications might go away, provided that no other software starts the service up again - for example, Microsoft Security Essentials uses the Windows Update service in order to check for definition updates, and will probably restart it periodically if it is not running. As Mark already suggested, you could disable the service to stop this happening.

A simpler solution is to drag the reminder window off the edge of the display so that it's out of your way.

share|improve this answer


  1. Services.msc
  2. Find the Windows update service.
  3. Stop it.
  4. Change startup type to "Disabled".

Please be sure to undo that once you're done for the day. Security updates are annoying but incredibly important.

share|improve this answer

Start gpedit.msc, go to Computer Configuration\Administrative Templates\Windows Components\Windows Update and set the policy No auto-restart with logged on users for scheduled automatic updates installations to Enabled.

share|improve this answer
I've already done that. Windows ignores it. – Mason Wheeler Sep 19 '12 at 23:04
That just prevents the system from rebooting without approval. It doesn't prevent notifications. – Harry Johnston Sep 20 '12 at 1:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .