Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I live in a hot and humid environment, therefore I monitor the hdd temperature using hddtemp and gkrellm. There is an LSI9211 8i sata/sas controller in my computer. I have drives connected to both my motherboard and the LSI. hddtemp monitors only the drives directly connected to my motherboard after booting the system, therefore gkrellm displays the temperature of those drvies only.

Logging in and restarting hddtemp before starting gkrellm fixes my issue, i.e. drives connected to the LSI controller are also visible. It seems that the drives connected to the LSI controller become visible only after hddtemp is started in the boot sequence. I think delaying it would help.

How can I delay the starting of hddtemp till all drives are visible? I prefer a way to check if drives are visible to the delay of a specific amount of seconds.

Two bootchart graphs (only the relevant part) attached. The boot sequence of the original setup. The other one is after applying the recommendation by Mikebabcock.

Original bootchart

Modified to execute hddtemp at the end

share|improve this question

1 Answer 1

You didn't mention your version of Linux, but assuming you're using one with init.d scripts, try something like vim /etc/init.d/hddtemp and change the priority on the 'chkconfig' line to 99, this will make it run pretty much at the end of the boot sequence.

Now do chkconfig hddtemp resetpriorities to change where it will start in the sequence. Best of luck if you're on a non-init.d system.

share|improve this answer
    
I use ubuntu 12.04. It uses init.d scripts, however chkconfig line is not used in any of the system services. –  Atis Sep 24 '12 at 2:04
    
I found that it uses upstart and dependencies on services are specified in the /etc/init.d/hddtemp file. I wonder if an event is emitted when all the drives are up and visible for the system. I have no idea how chkconfig interferes with it. –  Atis Sep 24 '12 at 2:25
1  
I managed to make the change by using update-rc.d hddtemp defaults 99. It does not help. See the bootcharts I attached to the original question. I need to delay the start of hddtemp until the logical volumes at the top of the charts (blkid, scsi_id, lvm. watershed sequence) are properly mounted. hddtemp is still to early. –  Atis Sep 24 '12 at 2:56
    
Sorry I'm not familiar with the "right way" to delay it in this case, but you could 'cheat' and add a simple sleep command to the start() section of your hddtemp boot script. There is typically a function or a switch line that says start and if you throw in sleep 30 between that and whatever commands it runs, the script will be delayed by 30 seconds. –  mikebabcock Sep 25 '12 at 13:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.