Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am working on configuring /mutt/ to send mail via /msmtp/. Strangely, if I user /msmtp/ from shell, all okay, that means, that .msmtprc is correct. However, mail sent with mutt do not come. I have this line in .muttrc.

set sendmail="msmtp"

How can I debug this problem?

EDIT:

I found, that if I send just text, like msmtp 'my-email' <<< "Hello", it works. But if I send fully builded email-header, it do not. Is it gmail politics or what?

share|improve this question
    
Have you tried setting set sendmail="/PATH/TO/msmtp"? –  Ansgar Wiechers Sep 20 '12 at 6:17

1 Answer 1

You should enter the full path to msmtp, like

set sendmail="/usr/bin/msmtp"

You might also consider setting the mutt options

sendmail_wait
use_from
envelope_from
from
realname
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.