Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I haven't seen a question like this anywhere, so I hope it isn't a duplicate.

Anyway, I have two computers, and one of them has its network connection through a LAN bridge in the other, which goes to a router. I want to set them up so that the one with the bridge is the server, and the other is the client.

I followed the instructions to get everything set up, and the client keeps saying that the connection timed out. Here are screenshots of Synergy running on the server and client, as well as one of the server's configuration.

Thanks in advance for the help!

share|improve this question

1 Answer 1

up vote 2 down vote accepted

The first step to take when troubleshooting connectivity (besides physical connectivity check) is to try and ping each device, and the devices in between (if applicable). You should also check that both devices are on the same subnet, and are pointed to the same gateway (if they are different gateways, you'll need to setup a Static Route in each gateway to the other device).

If you can ping both devices, your next step is to check for firewalls. These are likely on each computer, as well as the device used to bridge the LANs (depending on how exactly you've got your bridge set up).

If your bridge is something like a WiFi bridge, or other hardware-based routing method, it may use NAT and a firewall, which you'll have to configure. If it's software-based, like Hamachi, you'll need to make sure that each computer is actually using that virtual network adapter to establish the connection. You can configure which network adapter applications choose by default by going to Network Connections -> Advanced -> Advanced Settings. Then look at the Connections list, and re-order them so that Hamachi (or other software bridge) is on top. You may need to reboot for changes to take effect.

share|improve this answer
    
Hmm, interestingly enough, when I was checking IP addresses, I found that Synergy was reporting the wrong IP address for the server. It said 192.168.1.68, but ipconfig said 192.168.1.70. After I changed that, everything worked! Thanks for the help, though! –  bmozzy Sep 21 '12 at 0:55
    
I want to say that pinging the different ip's it gave me to connect to told me what one was correct. Also I wanted to up-vote QuickDanger's post but couldn't due to lack of rep. –  user265216 Oct 20 '13 at 9:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.