Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I am plugged in my laptop runs great however when I unplug it and I'm on battery power my CPU clock speed scales down pretty much all the way.

I know this is happening by monitoring the clock speed. When plugged in it will usually stay between 1000MHz and 3000MHz but when I unplug it it quickly scales down to less than 500MHz and will get as low as 100MHz and it will NEVER scale up at all on battery power. After I plug the power back in it will then begin operating normally in about a minute.

I have tried setting the MIN and MAX CPU performance in power options to 100% and have tried messing around with cooling settings which seemed to be a problem with HP laptops. I have a Toshiba Satellite M500-ST6444 running Windows 7. The BIOS is up to date. I have tried two versions.

share|improve this question

migrated from serverfault.com Sep 20 '12 at 14:08

This question came from our site for professional system and network administrators.

    
a toshiba what? running windows what? –  Carl B Sep 20 '12 at 14:15
1  
@CarlB - Why would the version of Windows matter in a case like this? Besides...the author indicates what version he is using. I really wish people could be voted down for idiotic comments. –  Ramhound Sep 20 '12 at 14:18
    
@Ramhound - you can flag it as unconstructive if you like.Be nice. Treat others with the same respect you’d want them to treat you. We’re all here to learn together. Be tolerant of others who may not know everything you know. Bring your sense of humor. –  Carl B Sep 20 '12 at 14:21
1  
The problem is not that it scales down.(which is good), but that it never scales back up again. This can have many causes, one of which is broken ACPI tables. These are part of the BIOS. It is worth checking if there is a new BIOS version for your laptop and reading the changed notes. –  Hennes Sep 20 '12 at 14:24
1  
@Hennes I previously updated my bios from 1.7 to 1.9 with no noticeable changes. I didn't see anything in the change logs referencing what you were suggesting. –  Ryan Sep 20 '12 at 14:44

1 Answer 1

Try these steps below:

  • Go to Control Panel
  • Select Power Options
  • Click Change Advanced Settings
  • Scroll down to Processor Power Management
  • See if the minimum and maximum are 5% and 100% respectively

You can do this for all Power plans on your computer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.