Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use iTerm2, with oh-my-zsh and zsh and in my .zshrc file I set a couple of my prompts to the unicode bolt symbol as follows.

ZSH_THEME_GIT_PROMPT_DIRTY="%{$fg[yellow]%}⚡%{$reset_color%}"
RPROMPT="%(?..%{$fg[white]%}%?%{$fg[red]%}⚡)%{$reset_color%} ${ruby}"

This was all fine an dandy until I recently upgraded to Mountain Lion and a new MacBook Pro Retina. Now, my super cool lighting bolt, which use to display as a normal character, is super flash and is actually composed of yellow in the middle and orange along the edges. Unfortunately, I can't enjoy enjoy the effect because whatever is rendering this is causing the area around it to become transparent in iterm. This means, whatever is below the window is rendered in the area around the character.

Over a black background things are fine.

Over any other color things suck.

If someone could let me know how to fix this issue, or disable the fancy bolt I would be very appreciative. Thanks

share|improve this question
    
On my 10.7 machine, that character (U+26a1) is one of the few emoji characters iTerm2 will display, perhaps because it isn't in the private-use range. The other characters, being far fancier, seem more like small graphics than font characters. Perhaps in 10.8, something about that character has changed, and iTerm2 is rendering it with a transparent background. I don't know if the behavior you are seeing is correct or not, but I would contact the iTerm2 developers directly to report as a bug, or to receive an explanation for what you are seeing. –  chepner Sep 22 '12 at 16:54
    
I have the same issue (on 10.8), all colored unicode characters (e.g. Emoji) are displayed with full transparency around them (regardless of what iTerm window's background transparency is set to). All I know is that it works correctly under Terminal.app –  Dan Feb 9 '13 at 15:25

1 Answer 1

The latest iTerm2 beta builds have this fixed. I can confirm that it is fixed in iTerm2-1_0_0_20121224.zip, but you'll probably want to run the latest build available. See this for the latest builds. They don't show up in the updates for me, even with Beta builds check enabled.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.