Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Despite having

vmmouse.present = "FALSE"
mouse.vusb.absDisabled = "TRUE"
pref.motionUngrab = "FALSE"

in my .vmx file and a customized VMware Tools installation on the guest that does not include the mouse driver, I somehow have fully integrated mouse support for my Windows 7 VM. I can smoothly mouse from the host into the guest without needing to click or Ctrl+G in and Ctrl+Alt out. I don't want this because of the issues it causes with games.

How can I get the VM to have no special mouse support while still having VMware Tools installed for its other functions (network, graphics, etc.)? The mouse works as I want without VMware Tools but not otherwise — again, despite not installing the mouse driver and having all those settings trying to disable it. Device Manager shows that the generic Windows PS/2 mouse driver is being used and not the virtual mouse driver.

Guest and host are both Windows 7 Ultimate SP1, x86 and x64 respectively. I'm using VMware Player 3.1.4 and the VMware Tools installed is the latest, 8.4.6.16648.

share|improve this question

3 Answers 3

In the guest, you probably need to go into device manager, for your mouse, and do a manual "Update Driver...", and tell it to let you pick from a list of devices, and select the standard mouse driver rather than the VMware mouse. You can also try "uninstalling" the mouse, and check the box prompting whether you want to also delete the driver files.

share|improve this answer
1  
OK. I don't mean to deflect attention away from SU, but you may be able to get better support for this by asking over on the VMware Community forums. VMware employees and gurus trawl over there more often than here. I'm a fairly casual VMware Workstation user so I unfortunately don't know the direct answer, although the answer is interesting to me, so +1 for the question. Good luck! –  allquixotic Sep 20 '12 at 21:10

This workaround that you've come up with is almost certainly unnecessary.

To fix (what I think is) your problem, go into VMware Preferences and change Optimize Mouse for Games to Always.

enter image description here

Note that you need to use VMware Workstation (Windows/Linux) or VMware Fusion (Mac OS X) to have this option available to you. I don't believe it's available in VMware Player.

share|improve this answer
    
Player is pretty basic; if it doesn't support a feature...well, for everything else there's MasterCard. This is also a global preference, not a per-VM preference. –  Michael Hampton Sep 21 '12 at 22:40

It seems all you want is to disable is the automatic ungrabbing, right? I’ll just use Michael Hampton’s screenshot to illustrate:

bla

Disable the following option:

  • Ungrab when cursor leaves window

Optionally, you may also be interested in the other options:

  • Hide cursor on ungrab
  • Grab when cursor enters window

These options have been available since a very long time and should also be available in VMware Player.

The directive you tried to use, pref.motionUngrab = "FALSE", is not applicable in vmx files but the VMware product’s preferences.ini. It is tied to the “Ungrab when cursor leaves window” checkbox.

share|improve this answer
    
Even though the GUI doesn’t have these options, VMware Player 7 (Pro, at least) respects this setting when included in preferences.ini. –  Daniel B Jun 22 at 17:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.