Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just built a Windows 7 computer to go onto my home LAN and be accessed by all on the network, mostly running XP SP3.

Installed it as a single HD+DVD system, got it happy, then added my storage drives, set them up in the right order and letters, rebooted, and shared them. I couldn't access the computer at all from any XP machine. I set the password thingy in Windows 7 to NO, and now I can "see" all four shared drives from any machine, but can access only two of them.

Please tell me what's going on as I've done nothing different from one drive to the other, just installed and set up drive letters as normal, then shared the damn things.

The odd thing about it? The two 1.5TB drives that have a lot of data on board are accessible, the two nearly empty 500GB ones are not.

share|improve this question

1 Answer 1

NTFS filesystem permissions are most likely responsible for this if you can "see" the network shares from the XP computers. Filesystem permissions are distinct from SMB share permissions. The file sharing service runs as the Local System account, I believe, so make sure you don't have Deny permissions in the NTFS file permissions of the inaccessible hard drives. Change the permissions to be "wide open" on the root of the drive and on a test folder and make sure it works, then apply the changes to the entire drive if successful.

share|improve this answer
    
Hiya,Back again but problem fixed !!! Couldn't follow exactly your instructions, but got to thinking,,,reformatted both problem drives in XP and end of problem! –  colin Sep 25 '12 at 19:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.