Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

There is lots of messed up dependency. How can I resolve this problem?

It produces the following output:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'libjpeg62-dev' instead of 'libjpeg-dev'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:

 libkrb5-dev : Depends: krb5-multidev (= 1.8.3+dfsg-4squeeze6) but it is not going to be installed
 libnspr4-dev : Depends: libnspr4-0d (>= 4.8.6) but it is not going to be installed
                Depends: libnspr4-0d (<= 4.8.6-1.1~) but it is not going to be installed
 libnss3-dev : Depends: libnss3-1d (= 3.12.8-1+squeeze5) but it is not going to be installed
 libpcre3-dbg : Depends: libpcre3 (= 8.02-1.1) but 1:8.30-5 is to be installed
 rpm : Depends: libnss3-1d (>= 3.12.0~1.9b1) but it is not going to be installed
       Depends: librpm1 (>= 4.8.0) but it is not going to be installed
       Depends: librpmbuild1 (>= 4.8.0) but it is not going to be installed
       Depends: librpmio1 (>= 4.8.0) but it is not going to be installed
       Depends: rpm2cpio but it is not going to be installed
E: Broken packages

You will have to install the above packages yourself.

root@lab:/home/mirror0/chrome/g/chrome_g#

root@lab:/home/mirror0/chrome/g/chrome_g# apt-get install krb5-multidev

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 krb5-multidev : Depends: libkrb5-3 (= 1.8.3+dfsg-4squeeze6) but 1.10.1+dfsg-2 is to be installed
                 Depends: libk5crypto3 (= 1.8.3+dfsg-4squeeze6) but 1.10.1+dfsg-2 is to be installed
                 Depends: libgssapi-krb5-2 (= 1.8.3+dfsg-4squeeze6) but 1.10.1+dfsg-2 is to be installed
E: Broken packages

root@lab:/home/mirror0/chrome/g/chrome_g# apt-get install libgssapi-krb5-2

Failed also:

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  libkrb5-3 libkrb5support0
Suggested packages:
  krb5-doc krb5-user
The following packages will be REMOVED:
  libgssglue1 librpcsecgss3 nfs-common
The following packages will be upgraded:
  libgssapi-krb5-2 libkrb5-3 libkrb5support0
3 upgraded, 0 newly installed, 3 to remove and 17 not upgraded.
E: Could not get lock /var/cache/apt/archives/lock - open (11: Resource temporarily unavailable)
E: Unable to lock directory /var/cache/apt/archives/

Even with aptitude, I failed to install krb5-multidev

aptitude install krb5-multidev
The following NEW packages will be installed:
  comerr-dev{a} krb5-multidev{b}
0 packages upgraded, 2 newly installed, 0 to remove and 20 not upgraded.
Need to get 146 kB of archives. After unpacking 696 kB will be used.
The following packages have unmet dependencies:
  krb5-multidev: Depends: libkrb5-3 (= 1.8.3+dfsg-4squeeze6) but 1.10.1+dfsg-1 is installed and it is kept back.
                 Depends: libk5crypto3 (= 1.8.3+dfsg-4squeeze6) but 1.10.1+dfsg-2 is installed.
                 Depends: libgssapi-krb5-2 (= 1.8.3+dfsg-4squeeze6) but 1.10.1+dfsg-1 is installed and it is kept back.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     krb5-multidev [Not Installed]



Accept this solution? [Y/n/q/?] y
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 20 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
share|improve this question
    
Could you also post your sources.lst? This kind of thing can happen if you've installed something from testing and switched back to stable. –  terdon Sep 21 '12 at 10:38
1  
You could also try aptitude instead of apt-get. Not really to install, but, perhaps, it would give you a better error message / more clues to what exactly happened. (aptitude usually tries harder to find a way to install stuff, so you'll see a huge list of things it would install and remove in order to get it to work - that would give you an idea what you have in conflict with what you are trying to install). –  wvxvw Sep 21 '12 at 13:04
    
Also, "unable to get lock" may mean couple of things: you are running apt-get from another terminal, and it didn't finish yet. You have something else interfere with installation process. You have no permission to do that (must be root). You could accidentally damage the package list by cancelling in the middle of install. Try dpkg with, iirc -f to do a sanity check on packages you have. (look at man dpkg first, I might had it wrong). –  wvxvw Sep 21 '12 at 13:08
    
@wvxvw even with aptitude, i failed to install krb5-multidev, i have added details above. –  hugemeow Sep 22 '12 at 4:22
    
see if this infro can help you: packages.debian.org/sid/krb5-multidev it says it is known to conflict with heimdal-dev. While it says it can be installed alongside, I'd be suspicious about that, perhaps, if you have that installed, I'd uninstall, install kerberos and then reinstall heimdal. –  wvxvw Sep 22 '12 at 7:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.