Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How do I fix the error that started popping up in a lot of applications:

To run this application, you first must install one of the following version of the .Net Framework: v2.0.50727.

Would you like to download an install version v2.0.50727 of the .NET framework now?

Unfortunately, this is not as simple as just installing the .NET 2.0 runtime, because its already installed. If I run the recommended installers for .NET 2.0 or .NET 3.5 SP1, it exits silently.

Events leading to problem:

  • Installed SQL Server 2008 R2, which installs a toy version of Visual Studio 2008 that only deals with SQL specific projects.
  • Uninstalled Visual Studio 2008.
share|improve this question
1  
Have you tried uninstalling and reinstalling the .NET 2.0 runtime? –  martineau Sep 21 '12 at 14:08
    
You would only get this error if the .NET Framework 2.0 was not installed. –  Ramhound Sep 21 '12 at 14:50
    
I would go ahead and reinstall everything you removed. –  Ramhound Sep 21 '12 at 14:56
    
You uninstalled the VS-2008. So I think it also uninstalled the .net framework 2.0 too so try to download a standalone setup for this problem and try to install it then. Also check out event log if there is any valuable information you got. –  avirk Sep 21 '12 at 15:01
    
Did you try reviewing Windows Event Viewer? It sometimoes offers interesting information. –  Sopalajo de Arrierez Mar 6 at 7:04
add comment

3 Answers

up vote 1 down vote accepted

I've often seen situations similar to this related to corruption in the installed .Net installation. Martineau's suggestion of uninstalling and reinstalling the .Net is probably in the right ballpark.

You can get this error with the .Net still installed if the program throwing the error does not DETECT the installation. Uninstalling/reinstalling will help with that. After you've uninstalled the existing .Net package, you might read through this article about the most recent Cleanup utility from MS. If removal of some other application left corrupted system connections, you might need that cleanup in order to get your system back to rights.

share|improve this answer
    
Thanks for the feedback! Much appreciated. –  Contango Mar 9 at 11:05
add comment

It would help if you specified which version of Windows this relates to.

You can check the Registry entries to see if the values applications should be using to verify which versions of the .NET Framework are installed have been corrupted.

If you are using a version of Windows for which .NET Framework 2.0 cannot be uninstalled, this article has some suggestions.

share|improve this answer
add comment

Installing .net 4.0 solved a similar issue for me before. I don't know why...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.