Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Mac Mini, late 2011, with Mac OS X Lion on it. Today I rebooted my machine and after that, the Mac couldn't load the GUI anymore and continuously tried to load the logon screen.

The OS worked, sshd worked, VNC and Samba shares worked, but I didn't get a GUI.

I ran Recovery with Command key and made a HDD and memory test. I also repaired permissions and the hard drive.

share|improve this question
1  
Do you remember installing anything before that reboot? Do you have a recent backup you could restore to using Recovery mode? Where exactly is the machine stuck? Does it show the grey screen and the Apple logo? Does it chime with the Apple sound? Does it get stuck at a blue screen? Or does the screen turn black? –  slhck Sep 21 '12 at 14:43
    
noting installed. but i find sommething(the reason that i go to restart befora chrash), sommething happend with my file assotiations and everithing was gone to open wit a wrong program. After reboot, i see the apple logo screen, then screen blink to black and then again in grey, byt dont see my login windows. The mac boot, and load. I can log on with putty to ssh and everithing lock ok. i can log to my sftp server, samba file share. only login windows dont load and GUI . –  Ivaylo Iliev Sep 21 '12 at 15:33
    
What happened with file associations exactly? Can you remember doing anything that would trigger that behavior? –  slhck Sep 21 '12 at 16:55
    
I download a picture from friend on Skype. After I try to open that picture was open with Fireworks, not with default program Preview. I change default program for *.jpeg file for all *.jpeg files but Preview don't open anything. Then i try to open a *.pdf (default by preview), but *.pdf was opened by Adobe Illustrator!?!?!?! Then i change default program for *.pdf files to Preview and try to open it, but just like jpeg the pdf file cannot open with Preview. I think may be Preview just don't work..... and then i decide to restart my MacMini –  Ivaylo Iliev Sep 21 '12 at 19:31
    
After this restart i cannot run in GUI. The Mac run, i see Apple logo, screen, then blink once from gray to black and back to gray and after this second gray appear only spinning gear and mouse from time to time i can see on screen. Otherwise Mac is run, os x boot and run. I can connect from ssh, sftp and samba and operate with file command and etc. but not have GUI because i cannot login, probably because i don't have a login screen :-) –  Ivaylo Iliev Sep 21 '12 at 19:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.