Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed the newest X11. I run the following command unsuccessfully after sourcing ~/.profile

$exec /usr/X11/lib/X11/xinit/xinitrc

I get a message

Screen is terminating

and I do not see any evidence of XMonad.

I run the command the second time, and I get

zsh: permission denied: /usr/X11/lib/X11/xinit/xinitrc
Process completed

and my terminal shuts down.

How can you have the full-screen mode in Mac's Xmonad by xinitrc?

share|improve this question

migrated from Sep 21 '12 at 16:35

This question came from our site for professional and enthusiast programmers.

Please, close this, since it is no longer relevant. The problem was a combination of different problems. – Masi Jun 7 '09 at 17:55
other people might run into the same problems, and stumble onto your question when trying to solve them - write up your experience as an answer! – Charles Stewart Feb 26 '10 at 16:38
up vote 2 down vote accepted

exec is a shell built-in. If you insists on using it with sudo, you should do something like:

sudo bash -c "exec ...."

But that is pretty much pointless, if you use sudo anyway. Just drop the "exec" altogether.

share|improve this answer
Yep. Sudo was not the solution to the problem. I left the sudo out. The problem still persists. – Masi May 23 '09 at 10:30

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.