Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm facing a strange issue whereby ALL the browsers on my home computer (Chrome, Firefox, Safari, IE, Opera) are defaulting to Arial Black. The font settings are normal - Times New Roman, Arial, Courier etc. - but that doesn't seem to be making a difference.

This is how the web should look:

This is how the web should look

And this is how it looks on my computer:

This is how it looks on my computer

I thought it might be a rogue extension, but then how would this affect both Chrome and Firefox. I have NO add-ons installed in Firefox. And what about Safari and IE?

I have a similar problem with my work computer, but the font there isn't Arial Black. I don't know what font it is, but it's not the regular Arial.

Where can I start looking?

I am running Windows 7 Ultimate x64 on an mid-2011 iMac. This problem does not occur when I am in Mac OS X on the same computer.

share|improve this question
    
Something's borked in your Windows Fonts folder. Messed-up permissions? –  kreemoweet Sep 22 '12 at 0:19
    
I checked that the first. Nothing seems wrong. All fonts are present and are opening fine. I even downloaded some default fonts pack (shared on some Windows 7 forum) and replaced existing fonts, but that didn't make any difference. –  aalaap Sep 22 '12 at 5:47

2 Answers 2

If somehow you lost the Arial font, Windows will default for the next closest option. Search for Arial, you might only find Arial Black being installed in your computer. Reinstall Arial and problem solved.

share|improve this answer
    
Confirmed. Client had somehow corrupted (or installed accidentally over) the default Arial font. Grabbing the font from another computer and reinstalling the Arial font fixed the problem for us. When we viewed the font in the font explorer, all fonts but "Arial Black" showed up as shortcuts. Reinstallation fixed them to not be shortcuts and everything worked almost immediately without the need to reboot. –  slickplaid Sep 24 at 16:31

I have recently had this problem. It was because I had recently installed Helvetica Neue font and it was messing with FireFox. Hopefully if you have that and uninstall it, it will fix the problem for you like it did me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.