Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I got my hands on a Ubuntu System (which was displaying correctly) and I installed CentOS 6.3. The screen is wrapping around on itself. Any ideas?

See for yourself

share|improve this question

migrated from Sep 21 '12 at 19:11

This question came from our site for system and network administrators.

Try setting multiple desktops – blogger Sep 22 '12 at 5:14

Added nomodeset to the end of the kernel line in /boot/grub/grub.conf.

share|improve this answer

I ran into the same problem installing CentOS 6.3 from the LiveCD on a Lenovo T530 laptop with a 1600x900 screen. I managed to hack my way through the installation, First Boot and log in with the screwed up screen. Sadly the desk top was just as messed up. I tried to analyze the situation w/o any luck. I tried googleing for an answer, but had no luck on that front either.

In frustration I tried several installations, but got no where. Finally I found a key. Near the beginning of the installation I was given a choice about video. In the unsuccessful installations, I let it default. The second time around I chose "minimal". I do not have the laptop available and my CentOS VM does not offer any such option so I can not give you the exact wording of the choice. This installation process came up readable, as did the First Boot and the desktop.

I will note that somewhere in the CentOS installation hacking I changed the UEFI option from Auto to Legacy Only. Perhaps that has some bearing on the problem. It would make sense that Ubuntu's newer kernel would handle UEFI better than the older CentOS code. There is a UEFI version of the CentOS minimal install. I did not get around to trying that.

I do know that I had the UEFI Legacy Only option set when I chose the "minimal" video option. With both conditions met, I had a working CentOS 6.3 on my laptop.

I have absolutely no insight into the whys and wherefores of the solution. I just managed to get CentOS 6.3 installed and running properly on my laptop. BTW, the full 1600x900 resolution was available on the laptop.

I was interested to see your post. I had wrongly assumed that the problem was related to the 1600x900 display.

Best of luck. Please let us know whether any of this worked.

share|improve this answer
I am the author of the second answer. I just installed CentOS on a new T530. The reference to "minimal" should read "Basic Video". It was the key. Attempting to install with the UEFI option set to "Legacy" but without the "Basic Video" resulted in a wrapped screen. – azjp Feb 20 '13 at 16:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .