Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is the first time I encounter this issue. I can't boot from USB drive on a Sony Vaio PCG-21313M. I set the external device as first choice and enabled it. Also I tested the usb (Windows 7) on other laptops and it boots fine. The computer doesn't boot properly not even in safe mode.

share|improve this question
    
external device thumb drive or cd/dvd drive? If external cd/dvd, does bios see the drive on boot? Does it use 2 usb ports to power up or one? netbook plugged in or on battery? –  Logman Sep 21 '12 at 23:31
    
Try pressing F12 during boot, to bring it up in the network BIOS. –  Daniel R Hicks Sep 21 '12 at 23:53
    
I don't have an external cd rom. It is a mini laptop, so it should boot from usb... netbook plugged in. –  Claudiu Sep 22 '12 at 8:51
    
Press the F2/F12 whatever key which belongs to enter in the Bios setup and then change the boot sequence, also change it when you have plugged in the bootable USB drive, it will show up there by its name whatever you have chooses for it and put it on the top. As my personal experience with my laptop there are two options for the bootable USB drive. 1: USB Drive 2: USB key. 1st one boot form the external HDD and 2nd boot form the bootable USB drive. –  avirk Sep 22 '12 at 10:49
    
@avirk From the question you can see that I've already done that. –  Claudiu Sep 22 '12 at 11:30

4 Answers 4

up vote 2 down vote accepted

I have experiences similar issue, then I found Boot mode setting in BIOS. It was set on IUF and I changed it to Legacy and it works! Hope it will help you.

share|improve this answer
    
Funnily enough this worked for my Vaio. In the past I've not been able to use Legacy install modes on my computers, always had to use UEFI, so hadn't considered changing this option until your answer. +1 for you :) (Maybe difference between custom made PC's and 'off-the-shelf' PC's?) –  Nukeface Aug 3 at 10:52

I tried using an ubuntu usb with no success. Then I tried using nolapic feature of ubuntu and it finally booted as a virtual machine, without installing. It let me backup my hdd. Hope this solution might help someone.

share|improve this answer

Go to the BIOS and change your boot location (Removable Disk) and Disable your Hard Drive. When finish your Windows 7 installation, return to the BIOS and Enable your Hard drive.

share|improve this answer

If your drive is bootable then follow this step.

  1. Go to bios by pressing "F2" on power on, to enter bios.
  2. On boot priority section enable "external boot".
  3. Set "external" as first priority and "internal hdd" as last. by pressing "F5/F6"

I am sure it will work, Make sure "internal hdd" is at last priority, because if it is not sometime it did not boot from "eternal" although it is set as first priority. unknown result.

If it did not work possibly you may problem with your external drive or data(boot-sector).

share|improve this answer

protected by Community Oct 24 '13 at 17:54

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.