Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Gigabyte GA-X79-UD3 motherboard and when I activate VT-d in the BIOS, I no longer get sound.

What can I do to avoid this problem?

share|improve this question
3  
Disable VT-d? :) –  techie007 Sep 22 '12 at 14:59
    
I have the same problem.. obviously this is bad because some people want to have both virtual machine and sound on the host. –  Boppity Bop Apr 19 '13 at 9:16
    
@BoppityBop I have no XPs with VirtualBox (as you mentioned bellow) and IOMMU, but if everything is set properly, it's probably a board bug, but I don't see any fix on this gigabyte.com/products/product-page.aspx?pid=4050&dl=1#bios –  dmnc Apr 25 '13 at 10:37
    
This is probably a common problem forums.whirlpool.net.au/archive/1922493 –  dmnc Apr 25 '13 at 10:43
add comment

1 Answer

Intel VT-d is "Virtualization Technology for Directed I/O" (IOMMU), used for re-mapping devices to virtualized guests. From your question is not clear your situation but I guess you have nothing to do with virtualization, so keep VT-d disabled.

In case you do virtualization and re-mapping soundcard to the guest, it's correct that soundcard has been unbinded from the host.

share|improve this answer
1  
I have virtual box and it doesn't use sound. and I still have audio disable on the host.... it seems to me that this is the mobo/dirvers thingy rather than VT-d itself in this case (I have GA-X79-UD3) –  Boppity Bop Apr 24 '13 at 17:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.