Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am VERY new to rsync and cygwin and I'm pretty sure I've installed everything correctly. I am trying to (for now) just rsync two Windows XP Laptops to tranfer files across from the one to the other to get a feel of it before I tackle bigger projects.

This is the code I try use to transfer the files but I always get the same error.

$ rsync -zrptL -v -e 'ssh -p 222' /tmp/rawr/
Admin@ Admin@'s password:

'rsync' is not recognized as an internal or external command, operable
program or batch file.

rsync: connection unexpectedly closed (0 bytes received so far)

rsync error: error in rsync protocol data stream (code 12) at

What could be the problem? I am really stuck at the moment.

share|improve this question

migrated from Sep 22 '12 at 19:26

This question came from our site for professional and enthusiast programmers.

Make sure that the laptop acting as the remote has the sshd daemon running. Also make sure your versions are the same and just to make sure all is good, specify the absolute path to ssh.

Have you tried rsync locally on both laptops? For example on laptop A do 'rsync /cygdrive/c/tmp /cygdrive/c/tmp2' to make sure that rsync works locally first. Then try to tackle it over the network.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.