Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My friend's computer has a problem where the USB ports causes problems with the power of some devices connected to the computer.

The USB mouse has no problems, however the Wireless Adapter looses power after around 20 seconds of use and USB Flash Drives cause the computer to either freeze, lose power (and become unresponsive) or become disconnected (still shown in Device Manager, but not in My Computer) when trying to transfer any type of file to / from the computer.

I have a suspicion it's the Motherboard but could it also be a Software problem? Tried a new case, RAM, CPU and GFX Card which had no effect.

The problem occurs on both the Front USB and Back (Motherboard) USB Ports.

UPDATE: Tried the USB devices with an Ubuntu Live CD and they work fine, could this mean it's a problem with Windows (x64)?

share|improve this question
Did you try a new PSU as well? – Karan Sep 22 '12 at 21:25
No. The computer is equipped with a 300W PSU, so that should be enough - it's not a high-end PC (3.0Ghz Pentium D, 4GB DDR2 RAM, Geforce 8600gt) I've updated my original question. I think it could be software based problem involving Windows as they work fine on Ubuntu 12.04 Live CD – Stefan Dunn Sep 22 '12 at 23:03
up vote 2 down vote accepted

The solution was to disable "Allow this computer to turn off this device to safe power" on both the Wireless adapter and all USB Root Hubs showing in "Device Manager".

share|improve this answer

The devices working in Ubuntu but not in Windows suggests a software problem, probably a driver problem. Try reinstalling the drivers on the wireless adapter and see if that helps (and get the most recent drivers from the manufacturer's website).

share|improve this answer
What would you suggest about the USB drivers? There are none on the Manufacturers website. – Stefan Dunn Sep 24 '12 at 8:41

This worked for me: Go to the Advanced Settings in the Power Options and Change the USB selective suspend setting to 'Disabled'.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .