Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Recently, I switched from initscript to systemd followed this wiki, and I got error like this during boot:

Job dev-md126p5.device/start timed out

This is my fstab:

/dev/mapper/VGLinux-lvroot / ext4 rw,relatime,stripe=64,data=ordered 0 1
/dev/mapper/VGLinux-lvhome /home ext4 rw,relatime,stripe=64,data=ordered 0 2
/swapfile none swap defaults 0 0
/dev/md126p5 /media/data ntfs-3g uid=xiaoxing,gid=users 0 0

Here is my partition scheme: I have two hard drives which are identical and as default, it is a raid0. Three partitions like this:

  1. windows 7, 200GB, ntfs
  2. linux, 100GB, lvm / , 30GB, ext4 /home , 30GB, ext4 the rest for future expend.
  3. data, rest, ntfs

After the "timed out", it throws me into an emergency mode, I can mount the data partition manually, and run "systemctl default", it will start the system properly. Or I can comment out the "data" part in the fstab file, and get into the system and mount it easily.

There is no problem before I switched to systemd. Now I've tried everything including write my own .service file to mount it, but it still can not mount the partition during boot. Any ideas?


The error above was from the journalctl, the error printed on screen during boot is:

[ TIME ] Timed out waiting for device dev-md126p5.device.

And followed by a lot of [ DEPEND ], then I am in emergency mode.

I am just curious what is the cause? Is it because it is on a raid, or because it is a ntfs partition?

share|improve this question

It looks like /dev/md126p5 takes a relatively long time to setup and become visible to systemd, thus causing the timeout error. Try setting a long timeout value in /etc/fstab. E.g.:

/dev/md126p5 /media/data ntfs-3g x-systemd.device-timeout=60s,uid=xiaoxing,gid=users 0 0

The x-systemd.device-timeout=60s option tells systemd to wait up to 60 seconds for the device to show up before giving up on it. Tweak the timeout value until it mounts reliably every time you boot up.

share|improve this answer
I've tried, but it's the same, in fact, before I add the 'timeout' option, it waited longer than 60s. After it timed out, I can mount the partition instantly. – dawnstar Sep 23 '12 at 5:44
@dawnstar: Is it possible that systemd doesn't see your device as /dev/md126p5? Have you tried changing the entry in /etc/fstab to use LABEL= or UUID= to identify the filesystem to mount? – Steven Monday Sep 23 '12 at 16:04
Yeah, I've tried that too, no luck. – dawnstar Sep 23 '12 at 21:28

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.