Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed postfix and dovecot on Ubuntu 10.04 using pdm-ubuntu-10-04-x86-v1.4.3. It set up a MySQL database for my domain and user data. I used it's ./manage to create a user. When I created an account in my outlook express (on my windows computer) It acts like I am putting in a bad password. I know it's connecting enough to try because the server name is like mail.domain.com and if I change that to cname.domain.com I get "the host ... could not be found", so I changed it back.

If I telnet from my linux shell, I can access dovecot and even read mail that I sent to myself from my yahoo account. If I telnet from my windows cmd, I get "-ERR Plaintext authentication disallowed on non-secure (SSL/TLS) connections."

I thought that might be a clue, so I went back to Outlook Express and turned on "Log on using secure password authentication" but then I get an error from OE

"Unable to logon to the server using Secure Password Authentication. Account: 'TecBrat', Server: 'mail.domain.com', Protocol: POP3, Server Response: '.', Port: 110, Secure(SSL): No, Error Number: 0x800CCC18"

What should I try next?

(I'm pretty new at this, so if you ask me to show a log or config file, please show me the expected path to find it.)

share|improve this question

migrated from unix.stackexchange.com Sep 23 '12 at 0:29

This question came from our site for users of Linux, FreeBSD and other Un*x-like operating systems..

    
I just tried adding the account to my gmail profile as well and got this message: "Server denied POP3 access for the given username and password." –  TecBrat Sep 22 '12 at 3:11
    
I tried to use Evolution on the same physical machine as the mail server and I get the same error I did trying to telnet in from Windows. –  TecBrat Sep 22 '12 at 3:38
    
This looks like a configuration problem on the Windows side. You should configure Outlook to use SSL (don't ask me how). –  Gilles Sep 22 '12 at 23:16

2 Answers 2

Secure password authentication in outlook express uses Windows NTLM/Kerberos auth.

Is in not simple SSL/TLS.

Do not enable it on linux unless you have GSSAPI/Kerberos configured.

Error 0x800CCC18 => http://support.microsoft.com/kb/202061

Reason is simple, you can not use secured login on unsecured connection.

Turn off "Log on using secure password authentication"

and change port settings accordingly to use POP over SSL (POPS = 995)

You must have dovecot configured to use SSL/TLS.

More info about standard mail service ports here :

http://www.emailaddressmanager.com/tips/mail-servers.html

Note that SSL/TLS enabled service can not be tested with telnet, you must use openssl.

More info here :

http://blog.yimingliu.com/2009/01/23/testing-a-pop3-server-via-telnet-or-openssl/

or here:

http://www.linuxplanet.com/linuxplanet/tutorials/7296/1

share|improve this answer
    
okay, thank you for that. So how do I get rid of "ERR Plaintext authentication disallowed on non-secure (SSL/TLS) connections" –  TecBrat Sep 22 '12 at 10:48

The solution I found is to add this line to /etc/dovecot/dovecot.conf:

disable_plaintext_auth=no

(or replace the existing disable_plaintext_auth=yes if it's already there)

Then restart dovecot:

# /etc/init.d/dovecot restart
share|improve this answer
1  
Your solution may fix it, but create big security flaw. –  rkosegi Sep 22 '12 at 11:44
    
My "solution" only fixed part of my problem because I couldn't send, so I started over with a tutorial from workaround.org that was written for Debian Squeeze. It was close enough that it got me squared away. –  TecBrat Sep 28 '12 at 21:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.