Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

A friend's machine running Windows XP refused to boot recently which is running 3 SATA disks on RAID 5 (which was previously upgraded from RAID 1 not by me). I have determined there to be a disk failure. The disks have been replaced many times in the past few years. I wish to backup the RAID5 partition before I try anything to fix it. The RAID chipset used is ICH10R/DO.

So, I plugged in an extra IDE drive and an Ubuntu USB key and looked at the RAID. The partitioning is a mess, but I did find at least one degraded but working RAID array with two partitions, one 79GB and the other 86GB.

Then I:

1) Partitioned my IDE disk using fdisk to have a partition of 80GB and bootable, and marked as NTFS.

2) dd the contents of the array to the partition

3) disconnected everything else

4) inserted a Windows XP CD and ran fixboot, fixmbr, and bootcfg. They all run ok and claim that they worked. (e.g. bootcfg detects the Windows partition, fixboot returns saying that it was written correctly.)

However, I'm still getting an error like "DISK FAILURE, BOOT DISK NOT FOUND".

I have tried running the GRUB rescue disk, which also runs ok, but won't boot into Windows. It just stops with a flashing cursor after chainloader +1, boot.

One clue may be that the partitions appear to be wack. One disk has a 79GB RAID partition on a 500GB drive with a offset, the second disk has a 320GB RAID partition across the whole drive. Additionally, the BIOS lists the RAID size as being 149GB. I don't see how this works. How are they even assembling the array when the partitions are so different?

I have also tried running the Windows XP automated repair tool, but that didn't work either.

I'm presuming this is something simple. Perhaps Windows is attempting to boot into RAID and, upon not finding it, simply crashing? Perhaps the 79GB partitions offset means that it's looking into the disk by that much?

Please help!!

To clarify: I want to make the single IDE disk bootable with a copy of the array so that I can prove/disprove that it's just that Windows has become corrupted, and use windows tools to correct it before attempting the same thing on the RAID array. That way I have a working backup and can show the process I used to fix it.

share|improve this question

migrated from Sep 23 '12 at 0:35

This question came from our site for system and network administrators.

up vote 0 down vote accepted

It turns out that on these types of RAID, the device is treated like a real disk, and not just a group of partitions like software RAID.

fdisk -l showed that the RAID array contained a partition table, so the dd should be from the array to the disk, not from the array to the partition.



dd if=/dev/mapper/MYRAID of=/dev/sda1


dd if=/dev/mapper/MYRAID of=/dev/sda

It surprises me that Windows can find itself and thinks that this is ok.

Anyway, now my Windows boots on a single disk copied from RAID. :-)

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .