Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I updated to the new Version of Aperture and it crashes every single time I want to open it.

Aperture then detected that the library needs to be repaired so it does that and then still crashes.

This is the crash info:

Process:         Aperture [317]
Path:            /Applications/Aperture.app/Contents/MacOS/Aperture
Identifier:      com.apple.Aperture
Version:         3.4 (3.4)
Build Info:      Aperture-301036000000000~1
Code Type:       X86-64 (Native)
Parent Process:  launchd [188]
User ID:         501

Date/Time:       2012-09-23 12:22:49.788 +0200
OS Version:      Mac OS X 10.8.2 (12C54)
Report Version:  10

Interval Since Last Report:          18520 sec
Crashes Since Last Report:           34
Per-App Interval Since Last Report:  814 sec
Per-App Crashes Since Last Report:   11
Anonymous UUID:                     

Crashed Thread:  4  Dispatch queue: com.apple.root.default-priority

Exception Type:  EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Application Specific Information:
*** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '*** -[NSURL initWithScheme:host:path:]: path 580972053 is not absolute.'
terminate called throwing an exception
abort() called

Application Specific Backtrace 1:
0   CoreFoundation                      0x00007fff92f4e0a6 __exceptionPreprocess + 198
1   libobjc.A.dylib                     0x00007fff8e2d23f0 objc_exception_throw + 43
2   CoreFoundation                      0x00007fff92f4de7c +[NSException raise:format:] + 204
3   Foundation                          0x00007fff8b170de8 -[NSURL(NSURL) initWithScheme:host:path:] + 112
4   PrintServices                       0x000000010e7fec6d +[NSURL(ISNSURLExtensions) URLWithScheme:host:path:] + 61
5   PrintServices                       0x000000010e7febef -[NSURL(ISNSURLExtensions) URLByAppendingPathComponent:] + 127
6   FacebookPublisher                   0x000000011c0d27f2 -[ILFacebookAPIRequest graphURLRequest] + 215
7   FacebookPublisher                   0x000000011c0d2fb5 -[ILFacebookAPIRequest send] + 33
8   FacebookPublisher                   0x000000011c0c44da -[IPHFacebookPlugin displayNameForUsername:] + 88
9   AccountConfigurationPlugin          0x000000010dd04fa5 -[AccountConfigurationProfileInformationDownloadOperation main] + 174
10  Foundation                          0x00007fff8b1c7986 -[__NSOperationInternal start] + 684
11  Foundation                          0x00007fff8b1cf1a1 __block_global_6 + 129
12  libdispatch.dylib                   0x00007fff898aff01 _dispatch_call_block_and_release + 15
13  libdispatch.dylib                   0x00007fff898ac0b6 _dispatch_client_callout + 8
14  libdispatch.dylib                   0x00007fff898ad1fa _dispatch_worker_thread2 + 304
15  libsystem_c.dylib                   0x00007fff8e651cab _pthread_wqthread + 404
16  libsystem_c.dylib                   0x00007fff8e63c171 start_wqthread + 13
share|improve this question

1 Answer 1

I had to re-install my old version of Aperture from DVD and then update to the latest version to fix the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.